aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorTing Liu <ting.liu@freescale.com>2014-07-23 11:58:56 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-07-23 21:55:51 +0100
commit7e7063e495d6451b46e06d08d16f92d0597a7d11 (patch)
tree7ad8915c3fcc577b1b78dc1b0453cf4b360063e9 /meta/recipes-kernel
parentd96b5072d53f134c5038601e30368db6ccfefe78 (diff)
downloadopenembedded-core-contrib-7e7063e495d6451b46e06d08d16f92d0597a7d11.tar.gz
perf: remove CFLAGS override
definition of __SANE_USERSPACE_TYPES__ was added in kernel source by commit e3541ec75219819d3235f80125a1a75d798ff6e1 perf tools, powerpc: Fix compile warnings in tests/attr.c Overriding the CFLAGS makes it impossible for kernel build system to append to it, thus making the build fail in various ways as: | CC /.../perf/1.0-r9/perf-1.0/perf.o | In file included from builtin.h:4:0, | from perf.c:9: | util/util.h:74:24: fatal error: lk/debugfs.h: No such file or directory | #include <lk/debugfs.h> | ^ | compilation terminated. Signed-off-by: Ting Liu <ting.liu@freescale.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/perf/perf.bb7
1 files changed, 0 insertions, 7 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 20968f98cc..222ae83c37 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -92,13 +92,6 @@ EXTRA_OEMAKE += "\
'infodir=${@os.path.relpath(infodir, prefix)}' \
"
-# PPC64 uses long long for u64 in the kernel, but powerpc's asm/types.h
-# prevents 64-bit userland from seeing this definition, instead defaulting
-# to u64 == long in userspace. Define __SANE_USERSPACE_TYPES__ to get
-# int-ll64.h included. And MIPS64 has the same issue.
-EXTRA_OEMAKE_append_powerpc64 = ' CFLAGS=-D__SANE_USERSPACE_TYPES__'
-EXTRA_OEMAKE_append_mips64 = ' CFLAGS=-D__SANE_USERSPACE_TYPES__'
-
PARALLEL_MAKE = ""
do_compile() {