aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/trace-cmd/kernelshark
diff options
context:
space:
mode:
authorPetter Mabäcker <petter@technux.se>2014-05-12 15:55:29 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-05-13 19:24:02 +0100
commitbc57d7041e126850245e4a5ab0211979b49b97ff (patch)
tree347a1262b20a81d354e9837fb02d1490df5c7de3 /meta/recipes-kernel/trace-cmd/kernelshark
parentaea206132384419f7f7c3514f9035eded1c5ef93 (diff)
downloadopenembedded-core-contrib-bc57d7041e126850245e4a5ab0211979b49b97ff.tar.gz
trace-cmd: refactoring recipe
Fixes [YOCTO #4497] Refactoring recipe to avoid duplicated entries in trace-cmd and kernelshark bb-files. Also remove usage of FILESPATH and split package unique patches into separate dirs. Signed-off-by: Petter Mabäcker <petter@technux.se> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/trace-cmd/kernelshark')
-rw-r--r--meta/recipes-kernel/trace-cmd/kernelshark/kernelshark-fix-syntax-error-of-shell.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-kernel/trace-cmd/kernelshark/kernelshark-fix-syntax-error-of-shell.patch b/meta/recipes-kernel/trace-cmd/kernelshark/kernelshark-fix-syntax-error-of-shell.patch
new file mode 100644
index 0000000000..faef049fec
--- /dev/null
+++ b/meta/recipes-kernel/trace-cmd/kernelshark/kernelshark-fix-syntax-error-of-shell.patch
@@ -0,0 +1,30 @@
+kernelshark: fix syntax error of shell
+
+Delete "<<<" syntax of bash in Makefile, else we would get following error:
+
+ Syntax error: redirection unexpected
+
+Upstream-Status: Pending
+
+Signed-off-by: Chong Lu <Chong.Lu@windriver.com>
+---
+ Makefile | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index c1fa906..be84415 100644
+--- a/Makefile
++++ b/Makefile
+@@ -89,8 +89,7 @@ endif
+
+ # $(call test-build, snippet, ret) -> ret if snippet compiles
+ # -> empty otherwise
+-test-build = $(if $(shell $(CC) -o /dev/null -c -x c - > /dev/null 2>&1 \
+- <<<'$1' && echo y), $2)
++test-build = $(if $(shell echo '$1' |$(CC) -o /dev/null -c -x c - > /dev/null 2>&1 && echo y), $2)
+
+ # have udis86 disassembler library?
+ udis86-flags := $(call test-build,\#include <udis86.h>,-DHAVE_UDIS86 -ludis86)
+--
+1.7.9.5
+