aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/sysprof/sysprof_3.22.2.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-11-28 15:34:13 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-30 15:47:15 +0000
commit9425992b59afa887fbbb1d3b3598f08757de4765 (patch)
tree0440c7ef4280b4bff5ab307f5ac8521602e51712 /meta/recipes-kernel/sysprof/sysprof_3.22.2.bb
parent24c7ed595adf16e90816e2ef7f6417740deb688d (diff)
downloadopenembedded-core-contrib-9425992b59afa887fbbb1d3b3598f08757de4765.tar.gz
sysprof: update to 3.22.2
Drop 0001-Forward-port-mips-arm-memory-barrier-patches.patch; upstream is using standard C11 facilities for this now. Drop 0001-callgraph-Use-U64_TO_POINTER.patch; it has been merged upstream. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-kernel/sysprof/sysprof_3.22.2.bb')
-rw-r--r--meta/recipes-kernel/sysprof/sysprof_3.22.2.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-kernel/sysprof/sysprof_3.22.2.bb b/meta/recipes-kernel/sysprof/sysprof_3.22.2.bb
new file mode 100644
index 0000000000..a1ed7c8b3b
--- /dev/null
+++ b/meta/recipes-kernel/sysprof/sysprof_3.22.2.bb
@@ -0,0 +1,34 @@
+SUMMARY = "System-wide Performance Profiler for Linux"
+LICENSE = "GPLv3+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
+ file://src/sp-application.c;endline=17;md5=40e55577ef122c88fe20052acda64875"
+
+inherit gnomebase gettext systemd
+
+DEPENDS = "glib-2.0"
+
+SRC_URI += " \
+ file://define-NT_GNU_BUILD_ID.patch \
+ file://0001-configure-Add-option-to-enable-disable-polkit.patch \
+ file://0001-Disable-check-for-polkit-for-UI.patch \
+ file://0001-Avoid-building-docs.patch \
+ "
+SRC_URI[archive.md5sum] = "2634bf35f5592e5e4520ccaba87e909e"
+SRC_URI[archive.sha256sum] = "d57fb19a3e5d4ad37d5fb554dc93d9a03f332779c3bffd9c2aa8f176e85269d7"
+
+AUTOTOOLS_AUXDIR = "${S}/build-aux"
+
+EXTRA_OECONF = "--enable-compile-warnings"
+
+PACKAGECONFIG ?= "${@bb.utils.contains_any('DISTRO_FEATURES', '${GTK3DISTROFEATURES}', 'gtk', '', d)}"
+PACKAGECONFIG[gtk] = "--enable-gtk,--disable-gtk,gtk+3"
+PACKAGECONFIG[polkit] = "--enable-polkit,--disable-polkit,polkit dbus"
+
+SOLIBS = ".so"
+FILES_SOLIBSDEV = ""
+FILES_${PN} += "${datadir}/icons/"
+
+SYSTEMD_SERVICE_${PN} = "${@bb.utils.contains('PACKAGECONFIG', 'polkit', 'sysprof2.service', '', d)}"
+
+# We do not yet work for aarch64.
+COMPATIBLE_HOST = "^(?!aarch64).*"