aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/powertop/powertop_2.9.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2017-10-12 17:41:47 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-11-05 13:44:56 +0000
commitc12f7f7492c33134ad6dde65fe119d53301dca2f (patch)
treef4d39d191a034a05ba8efd9ea383739d7fc3d26c /meta/recipes-kernel/powertop/powertop_2.9.bb
parent6e37a88af155d5e5453fb0f44bb11d6f8e406438 (diff)
downloadopenembedded-core-contrib-c12f7f7492c33134ad6dde65fe119d53301dca2f.tar.gz
powertop: update to v2.9
* Upstream filename added "v" before version: - Add UPSTREAM_CHECK_REGEX - Update SRC_URI to include the "v" - Point ${S} to proper directory * Patch for required headers no longer needed in current upstream * Tested on qemux86-64 core-image-full-cmdline image with multilib Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-kernel/powertop/powertop_2.9.bb')
-rw-r--r--meta/recipes-kernel/powertop/powertop_2.9.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-kernel/powertop/powertop_2.9.bb b/meta/recipes-kernel/powertop/powertop_2.9.bb
new file mode 100644
index 0000000000..4fe5447a03
--- /dev/null
+++ b/meta/recipes-kernel/powertop/powertop_2.9.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Power usage tool"
+DESCRIPTION = "Linux tool to diagnose issues with power consumption and power management."
+HOMEPAGE = "http://01.org/powertop/"
+BUGTRACKER = "http://bugzilla.lesswatts.org/"
+DEPENDS = "ncurses libnl pciutils"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
+
+SRC_URI = "http://01.org/sites/default/files/downloads/powertop/powertop-v${PV}.tar.gz \
+"
+
+SRC_URI[md5sum] = "583518c5c4434c6e9b9c58c3920950b6"
+SRC_URI[sha256sum] = "aa7fb7d8e9a00f05e7d8a7a2866d85929741e0d03a5bf40cab22d2021c959250"
+
+UPSTREAM_CHECK_URI = "https://01.org/powertop/downloads"
+UPSTREAM_CHECK_REGEX = "powertop-[v]?(?P<pver>\d+(\.\d+)+)\.tar"
+
+inherit autotools gettext pkgconfig
+
+S = "${WORKDIR}/${BPN}-v${PV}"
+
+# we do not want libncursesw if we can
+do_configure_prepend() {
+ # configure.ac checks for delwin() in "ncursesw ncurses" so let's drop first one
+ sed -i -e "s/ncursesw//g" ${S}/configure.ac
+ mkdir -p ${B}/src/tuning/
+}
+
+inherit update-alternatives
+ALTERNATIVE_${PN} = "powertop"
+ALTERNATIVE_TARGET[powertop] = "${sbindir}/powertop"
+ALTERNATIVE_LINK_NAME[powertop] = "${sbindir}/powertop"
+ALTERNATIVE_PRIORITY = "100"