aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/oprofile
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-08-19 23:48:10 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-30 12:34:06 +0100
commit2dff13e834dc7b67e16ee597d7f9a3efdc72d10f (patch)
treeca4c16e6d5363fbe9902e78935c473d2d2a6a466 /meta/recipes-kernel/oprofile
parentc45ded0d0cf4be56c124f288706caad89163aa68 (diff)
downloadopenembedded-core-contrib-2dff13e834dc7b67e16ee597d7f9a3efdc72d10f.tar.gz
oprofile: 1.0.0 -> 1.1.0
* Remove backport patch filemode-fix.patch. * Update --with-kernel=${STAGING_DIR_HOST}/${prefix} to find kernel headers (linux/*.h) to fix the error: | checking kernel supports perf_events... unknown -- perf_event.h not found | ERROR: You requested to build oprofile with '--with-kernel=/buildarea/lyang1/test_f2/tmp/work-shared/qemux86/kernel-source', | but headers were not accessible at the given location. | Be sure you have run the following command from within your kernel source tree: | make headers_install INSTALL_HDR_PATH=<kernel-hdrs-install-dir> | Then pass <kernel-hdrs-install-dir> to oprofile's '--with-kernel' configure option. | configure: error: Unable to build oprofile. Exiting. (From OE-Core rev: b2200152deef0aec3cd8fe55bb73d6e8fccfe159) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/oprofile')
-rw-r--r--meta/recipes-kernel/oprofile/oprofile.inc3
-rw-r--r--meta/recipes-kernel/oprofile/oprofile/filemode-fix.patch41
-rw-r--r--meta/recipes-kernel/oprofile/oprofile_1.0.0.bb11
-rw-r--r--meta/recipes-kernel/oprofile/oprofile_1.1.0.bb10
4 files changed, 11 insertions, 54 deletions
diff --git a/meta/recipes-kernel/oprofile/oprofile.inc b/meta/recipes-kernel/oprofile/oprofile.inc
index 6b393bc9e6..6ec56e7b33 100644
--- a/meta/recipes-kernel/oprofile/oprofile.inc
+++ b/meta/recipes-kernel/oprofile/oprofile.inc
@@ -19,7 +19,6 @@ FILES_${PN}-dev += "${libdir}/${BPN}/lib*${SOLIBSDEV} ${libdir}/${BPN}/lib*.la"
FILES_${PN}-staticdev += "${libdir}/${BPN}/lib*.a"
SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz \
- file://filemode-fix.patch \
file://acinclude.m4 \
file://automake-foreign.patch \
file://oprofile-cross-compile-tests.patch \
@@ -28,7 +27,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz \
inherit autotools pkgconfig ptest
-EXTRA_OECONF = "--with-kernel=${STAGING_KERNEL_DIR} --without-x ac_cv_prog_XSLTPROC="
+EXTRA_OECONF = "--with-kernel=${STAGING_DIR_HOST}${prefix} --without-x ac_cv_prog_XSLTPROC="
do_configure () {
cp ${WORKDIR}/acinclude.m4 ${S}/
autotools_do_configure
diff --git a/meta/recipes-kernel/oprofile/oprofile/filemode-fix.patch b/meta/recipes-kernel/oprofile/oprofile/filemode-fix.patch
deleted file mode 100644
index f7ebe24691..0000000000
--- a/meta/recipes-kernel/oprofile/oprofile/filemode-fix.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-With security_flags.inc:
-
-| In file included from /media/build1/poky/build/tmp/sysroots/qemumips/usr/include/fcntl.h:302:0,
-| from opjitconv.c:25:
-| In function 'open',
-| inlined from 'copy_dumpfile' at opjitconv.c:219:6:
-| /media/build1/poky/build/tmp/sysroots/qemumips/usr/include/bits/fcntl2.h:50:4: error: call to '__open_missing_mode' declared with attribute error: open with O_CREAT in second argument needs 3 arguments
-| __open_missing_mode ();
-| ^
-| Makefile:440: recipe for target 'opjitconv.o' failed
-
-Why does this only happen on mips? mips has:
-
-O_CREAT = 0x100
-and
-S_IRUSR = 0400
-
-and these (in hex and otcal) are equivalent. Most other platforms
-have O_CREAT = 0100.
-
-http://sourceforge.net/p/oprofile/oprofile/ci/4598ca73b0a367ca46d4a2843261e20e1896773b
-
-The file should not be created, only opened if its present, therefore use O_RDONLY instead.
-
-RP 2014/11/6
-
-Upstream-Status: Backport
-
-Index: oprofile-1.0.0/opjitconv/opjitconv.c
-===================================================================
---- oprofile-1.0.0.orig/opjitconv/opjitconv.c 2014-09-12 14:39:47.000000000 +0000
-+++ oprofile-1.0.0/opjitconv/opjitconv.c 2014-11-06 13:14:25.941639003 +0000
-@@ -216,7 +216,7 @@
- int file_locked = 0;
- unsigned int usecs_waited = 0;
- int rc = OP_JIT_CONV_OK;
-- int fd = open(dumpfile, S_IRUSR);
-+ int fd = open(dumpfile, O_RDONLY);
- if (fd < 0) {
- perror("opjitconv failed to open JIT dumpfile");
- return OP_JIT_CONV_FAIL;
diff --git a/meta/recipes-kernel/oprofile/oprofile_1.0.0.bb b/meta/recipes-kernel/oprofile/oprofile_1.0.0.bb
deleted file mode 100644
index b44b5c5b20..0000000000
--- a/meta/recipes-kernel/oprofile/oprofile_1.0.0.bb
+++ /dev/null
@@ -1,11 +0,0 @@
-require oprofile.inc
-
-DEPENDS += "virtual/kernel"
-DEPENDS_append_powerpc64 = " libpfm4"
-
-SRC_URI[md5sum] = "ba0b340e5c421a93959776c836ed35b3"
-SRC_URI[sha256sum] = "847110b4ecdcf8c8353cd38f94c1b704aad4bfcd9453e38b88d112cfb7e3c45a"
-
-S = "${WORKDIR}/oprofile-${PV}"
-
-PR = "r1"
diff --git a/meta/recipes-kernel/oprofile/oprofile_1.1.0.bb b/meta/recipes-kernel/oprofile/oprofile_1.1.0.bb
new file mode 100644
index 0000000000..92a94ad0d4
--- /dev/null
+++ b/meta/recipes-kernel/oprofile/oprofile_1.1.0.bb
@@ -0,0 +1,10 @@
+require oprofile.inc
+
+DEPENDS += "virtual/kernel"
+DEPENDS_append_powerpc64 = " libpfm4"
+
+SRC_URI[md5sum] = "248c4c069f9476f427fa7195563f9867"
+SRC_URI[sha256sum] = "cf759a6de1a6033d5dfc93bda129a9f2e128aecc4238cc657feb0801d1b0366c"
+
+S = "${WORKDIR}/oprofile-${PV}"
+