aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/modutils/files/program_prefix.patch
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/recipes-kernel/modutils/files/program_prefix.patch
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadopenembedded-core-contrib-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-kernel/modutils/files/program_prefix.patch')
-rw-r--r--meta/recipes-kernel/modutils/files/program_prefix.patch69
1 files changed, 69 insertions, 0 deletions
diff --git a/meta/recipes-kernel/modutils/files/program_prefix.patch b/meta/recipes-kernel/modutils/files/program_prefix.patch
new file mode 100644
index 0000000000..2927a23a22
--- /dev/null
+++ b/meta/recipes-kernel/modutils/files/program_prefix.patch
@@ -0,0 +1,69 @@
+--- modutils-2.4.25/Makefile.common.in Sun Nov 24 21:23:35 2002
++++ modutils-2.4.25/Makefile.common.in Thu Jan 29 17:16:30 2004
+@@ -7,6 +7,7 @@
+ mandir = @mandir@
+ prefix = @prefix@
+ sbindir = @sbindir@
++transform = @program_transform_name@
+
+ AR = @AR@
+ ARCH = @ARCH@
+--- modutils-2.4.25/configure.in Thu Jan 29 17:24:10 2004
++++ modutils-2.4.25/configure.in Thu Jan 29 17:13:59 2004
+@@ -17,6 +17,7 @@
+ export CC_FOR_BUILD
+
+ AC_CANONICAL_TARGET([])
++AC_ARG_PROGRAM
+
+ # Handle target_cpu for compatibility.
+ if test "$host_cpu" != "$target_cpu"; then
+--- modutils-2.4.25/depmod/Makefile.in Fri Mar 28 17:54:20 2003
++++ modutils-2.4.25/depmod/Makefile.in Thu Jan 29 17:16:41 2004
+@@ -60,7 +60,7 @@
+
+ install install-bin: all
+ $(MKDIR) $(DESTDIR)$(sbindir)
+- $(INSTALL) $(STRIP) depmod $(DESTDIR)$(sbindir)
++ $(INSTALL) $(STRIP) depmod $(DESTDIR)$(sbindir)/`echo depmod | sed -e'$(transform)'`
+
+ dep depend .depend: depmod.c
+ $(CC) -M $(CFLAGS) $(DEFSNOARCH) $(DEFS) $^ > .depend
+--- modutils-2.4.25/genksyms/Makefile.in Sun Nov 24 21:23:35 2002
++++ modutils-2.4.25/genksyms/Makefile.in Thu Jan 29 17:17:07 2004
+@@ -62,7 +62,7 @@
+
+ install install-bin: all
+ $(MKDIR) $(DESTDIR)$(sbindir)
+- $(INSTALL) $(STRIP) genksyms $(DESTDIR)$(sbindir)
++ $(INSTALL) $(STRIP) genksyms $(DESTDIR)$(sbindir)/`echo genksyms | sed -e'$(transform)'`
+
+ # auto-generated dependancies are almost redundant once we add all the
+ # rules to get the generated files built first.
+--- modutils-2.4.25/insmod/Makefile.in Fri Mar 28 17:54:20 2003
++++ modutils-2.4.25/insmod/Makefile.in Thu Jan 29 17:21:10 2004
+@@ -120,16 +120,19 @@
+ @set -ex;\
+ for i in $(TARGETS_REAL); do \
+ $(MKDIR) $(DESTDIR)$(sbindir); \
+- $(INSTALL) $(STRIP) $$i $(DESTDIR)$(sbindir); done;
++ f=`echo $$i|sed -e'$(transform)'`; \
++ $(INSTALL) $(STRIP) $$i $(DESTDIR)$(sbindir)/$$f; done;
+ set -e; \
+- for i in $(srcdir)/insmod_ksymoops_clean $(srcdir)/kernelversion; do \
++ for i in insmod_ksymoops_clean kernelversion; do \
+ $(MKDIR) $(DESTDIR)$(sbindir); \
+- $(INSTALL) $$i $(DESTDIR)$(sbindir); done;
++ f=`echo $$i|sed -e'$(transform)'`; \
++ $(INSTALL) $$i $(DESTDIR)$(sbindir)/$$f; done;
+ set -e; \
+ for i in $(COMB); do \
+- ln -sf insmod $(DESTDIR)$(sbindir)/$$i; \
++ f=`echo $$i|sed -e'$(transform)'`; \
++ ln -sf `echo insmod|sed -e'$(transform)'` $(DESTDIR)$(sbindir)/$$f; \
+ (test "$(insmod_static)" = yes && \
+- ln -sf insmod.static $(DESTDIR)$(sbindir)/$$i.static) || true; \
++ ln -sf `echo insmod.static|sed -e'$(transform)'` $(DESTDIR)$(sbindir)/$$f.static) || true; \
+ done
+
+ clean: