aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng
diff options
context:
space:
mode:
authorChong Lu <Chong.Lu@windriver.com>2013-11-18 13:41:14 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-11-18 12:36:39 +0000
commit95a0eb99b9fd88288b6f03c7d0173c392d25de28 (patch)
tree0c817ee09c2b4a0f32533c088c6d0b36138d7da9 /meta/recipes-kernel/lttng
parent2935e7b2fc3c1a35e810eb4043638ffcd6682d0c (diff)
downloadopenembedded-core-contrib-95a0eb99b9fd88288b6f03c7d0173c392d25de28.tar.gz
lttng-tools: Fixes incorrect path of ptest cases
In ptest cases, some paths are still the source code path. Continue to fix the paths of executable files in ptest cases to make them work on target. Signed-off-by: Chong Lu <Chong.Lu@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/lttng')
-rw-r--r--meta/recipes-kernel/lttng/lttng-tools_2.3.0.bb21
1 files changed, 13 insertions, 8 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-tools_2.3.0.bb b/meta/recipes-kernel/lttng/lttng-tools_2.3.0.bb
index f2a43b4cb5..49c0992068 100644
--- a/meta/recipes-kernel/lttng/lttng-tools_2.3.0.bb
+++ b/meta/recipes-kernel/lttng/lttng-tools_2.3.0.bb
@@ -38,17 +38,22 @@ INSANE_SKIP_${PN}-dbg = "libexec"
do_install_ptest () {
chmod +x ${D}/${libdir}/${PN}/ptest/tests/utils/utils.sh
for i in `find ${D}/${libdir}/${PN}/ptest -perm /u+x -type f`; do
- sed -e "s:\$TESTDIR.*/src/bin/lttng/\$LTTNG_BIN:\$LTTNG_BIN:" \
- -e "s:\$TESTDIR/../src/bin/lttng-sessiond/\$SESSIOND_BIN:\$SESSIOND_BIN:" \
- -e "s:\$DIR/../src/bin/lttng-sessiond/\$SESSIOND_BIN:\$SESSIOND_BIN:" \
- -e "s:\$TESTDIR/../src/bin/lttng-consumerd/:${libedir}/lttng/libexec/:" \
- -e "s:\$DIR/../src/bin/lttng-consumerd/:${libdir}/lttng/libexec/:" \
- -e "s:\$TESTDIR/../src/bin/lttng-relayd/\$RELAYD_BIN:\$RELAYD_BIN:" \
+ sed -e "s:\$TESTDIR.*/src/bin/lttng/\$LTTNG_BIN:\$LTTNG_BIN:g" \
+ -e "s:\$TESTDIR/../src/bin/lttng-sessiond/\$SESSIOND_BIN:\$SESSIOND_BIN:g" \
+ -e "s:\$DIR/../src/bin/lttng-sessiond/\$SESSIOND_BIN:\$SESSIOND_BIN:g" \
+ -e "s:\$TESTDIR/../src/bin/lttng-consumerd/:${libdir}/lttng/libexec/:g" \
+ -e "s:\$DIR/../src/bin/lttng-consumerd/:${libdir}/lttng/libexec/:g" \
+ -e "s:\$TESTDIR/../src/bin/lttng-relayd/\$RELAYD_BIN:\$RELAYD_BIN:g" \
+ -e "s:\$DIR/../src/bin/lttng-sessiond/lttng-sessiond:\$SESSIOND_BIN:g" \
+ -e "s:\$DIR/../src/bin/lttng-relayd/\$RELAYD_BIN:\$RELAYD_BIN:g" \
+ -e "s:\$DIR/../bin/lttng-relayd/\$RELAYD_BIN:\$RELAYD_BIN:g" \
-i $i
done
- sed -e "s:src/bin/lttng-sessiond:$bindir:" \
- -e "s:src/bin/lttng-consumerd:${libexecdir}/libexec/:" \
+ sed -e "s:src/bin/lttng-sessiond:$bindir:g" \
+ -e "s:src/bin/lttng-consumerd:${libexecdir}/libexec/:g" \
-i ${D}/${libdir}/${PN}/ptest/tests/regression/run-report.py
+ sed -e "s:src/bin:bin:g" \
+ -i ${D}/${libdir}/${PN}/ptest/tests/utils/utils.sh
}