aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng
diff options
context:
space:
mode:
authorRoy.Li <rongqing.li@windriver.com>2013-10-30 14:05:06 +0800
committerSaul Wold <sgw@linux.intel.com>2013-10-31 23:57:03 -0700
commit48067c2093e397255e41b0222da3b7612f1458a7 (patch)
tree5096d6070cde67c0f2a37ccfcb90f45d2b9cd7ff /meta/recipes-kernel/lttng
parentcb966afe86a5856d846fb0d4fb627cdce2ae0670 (diff)
downloadopenembedded-core-contrib-48067c2093e397255e41b0222da3b7612f1458a7.tar.gz
lttng-tools: make ptest able to work on target
The paths of executable files in test cases are the source code path, need to fix to make them work on target Signed-off-by: Roy.Li <rongqing.li@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-kernel/lttng')
-rw-r--r--meta/recipes-kernel/lttng/lttng-tools_2.3.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-tools_2.3.0.bb b/meta/recipes-kernel/lttng/lttng-tools_2.3.0.bb
index 4322027d7d..f2a43b4cb5 100644
--- a/meta/recipes-kernel/lttng/lttng-tools_2.3.0.bb
+++ b/meta/recipes-kernel/lttng/lttng-tools_2.3.0.bb
@@ -33,3 +33,22 @@ FILES_${PN}-dbg += "${libdir}/lttng/libexec/.debug"
# the libexec insane test so skip it.
INSANE_SKIP_${PN} = "libexec"
INSANE_SKIP_${PN}-dbg = "libexec"
+
+
+do_install_ptest () {
+ chmod +x ${D}/${libdir}/${PN}/ptest/tests/utils/utils.sh
+ for i in `find ${D}/${libdir}/${PN}/ptest -perm /u+x -type f`; do
+ sed -e "s:\$TESTDIR.*/src/bin/lttng/\$LTTNG_BIN:\$LTTNG_BIN:" \
+ -e "s:\$TESTDIR/../src/bin/lttng-sessiond/\$SESSIOND_BIN:\$SESSIOND_BIN:" \
+ -e "s:\$DIR/../src/bin/lttng-sessiond/\$SESSIOND_BIN:\$SESSIOND_BIN:" \
+ -e "s:\$TESTDIR/../src/bin/lttng-consumerd/:${libedir}/lttng/libexec/:" \
+ -e "s:\$DIR/../src/bin/lttng-consumerd/:${libdir}/lttng/libexec/:" \
+ -e "s:\$TESTDIR/../src/bin/lttng-relayd/\$RELAYD_BIN:\$RELAYD_BIN:" \
+ -i $i
+ done
+
+ sed -e "s:src/bin/lttng-sessiond:$bindir:" \
+ -e "s:src/bin/lttng-consumerd:${libexecdir}/libexec/:" \
+ -i ${D}/${libdir}/${PN}/ptest/tests/regression/run-report.py
+
+}