aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-ust_git.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-07-13 19:51:57 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-22 23:25:00 +0100
commitf5b03208c0ae0f47dddec6e39712fb0f1d041ebc (patch)
tree0d06018cda1b9453a1f09b6f25e80a84cb2d51c8 /meta/recipes-kernel/lttng/lttng-ust_git.bb
parent3157f8995e24f8a70492a261815be3a6fe51dcbd (diff)
downloadopenembedded-core-contrib-f5b03208c0ae0f47dddec6e39712fb0f1d041ebc.tar.gz
lttng-ust: 2.6.1 -> 2.6.2
* Remove add-aarch64.patch since it is already in the source. * Rename lttng-ust_2.6.1.bb -> lttng-ust_git.bb Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-ust_git.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-ust_git.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-ust_git.bb b/meta/recipes-kernel/lttng/lttng-ust_git.bb
new file mode 100644
index 0000000000..ae4afd3d89
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-ust_git.bb
@@ -0,0 +1,34 @@
+SUMMARY = "Linux Trace Toolkit Userspace Tracer 2.x"
+DESCRIPTION = "The LTTng UST 2.x package contains the userspace tracer library to trace userspace codes."
+HOMEPAGE = "http://lttng.org/ust"
+BUGTRACKER = "https://bugs.lttng.org/projects/lttng-ust"
+
+LICENSE = "LGPLv2.1+ & MIT & GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=c963eb366b781252b0bf0fdf1624d9e9 \
+ file://snprintf/snprintf.c;endline=32;md5=d3d544959d8a3782b2e07451be0a903c \
+ file://snprintf/various.h;endline=31;md5=89f2509b6b4682c4fc95255eec4abe44"
+
+inherit autotools lib_package
+
+DEPENDS = "liburcu util-linux"
+RDEPENDS_${PN}-bin = "python-core"
+
+# For backwards compatibility after rename
+RPROVIDES_${PN} = "lttng2-ust"
+RREPLACES_${PN} = "lttng2-ust"
+RCONFLICTS_${PN} = "lttng2-ust"
+
+SRCREV = "c49ee9040ada6984c880756614e8a6f7fd645bd6"
+PE = "2"
+PV = "2.6.2+git${SRCPV}"
+
+SRC_URI = "git://git.lttng.org/lttng-ust.git;branch=stable-2.6 \
+ file://lttng-ust-doc-examples-disable.patch \
+ file://lttng-ust-Fix-live-timer-calculation-error.patch \
+ "
+
+S = "${WORKDIR}/git"
+
+do_configure_prepend () {
+ ( cd ${S}; ${S}/bootstrap )
+}