aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-ust_2.10.2.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2018-11-16 14:10:18 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-11-17 22:57:36 +0000
commit1df9f7d6946c9a0ee0749ed8646446eb56878846 (patch)
treed64be31191a00bef89a5b27d30bbf682380477d9 /meta/recipes-kernel/lttng/lttng-ust_2.10.2.bb
parente06afc5cc6d848e63e1dd66425612c6a486a5a6c (diff)
downloadopenembedded-core-contrib-1df9f7d6946c9a0ee0749ed8646446eb56878846.tar.gz
lttng-ust: upgrade 2.10.1 -> 2.10.2
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-ust_2.10.2.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-ust_2.10.2.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-ust_2.10.2.bb b/meta/recipes-kernel/lttng/lttng-ust_2.10.2.bb
new file mode 100644
index 0000000000..3e5f37d886
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-ust_2.10.2.bb
@@ -0,0 +1,37 @@
+SUMMARY = "Linux Trace Toolkit Userspace Tracer 2.x"
+DESCRIPTION = "The LTTng UST 2.x package contains the userspace tracer library to trace userspace codes."
+HOMEPAGE = "http://lttng.org/ust"
+BUGTRACKER = "https://bugs.lttng.org/projects/lttng-ust"
+
+LICENSE = "LGPLv2.1+ & MIT & GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=c963eb366b781252b0bf0fdf1624d9e9 \
+ file://snprintf/snprintf.c;endline=32;md5=d3d544959d8a3782b2e07451be0a903c \
+ file://snprintf/various.h;endline=31;md5=89f2509b6b4682c4fc95255eec4abe44"
+
+inherit autotools lib_package manpages
+
+DEPENDS = "liburcu util-linux"
+RDEPENDS_${PN}-bin = "python3-core"
+
+# For backwards compatibility after rename
+RPROVIDES_${PN} = "lttng2-ust"
+RREPLACES_${PN} = "lttng2-ust"
+RCONFLICTS_${PN} = "lttng2-ust"
+
+PE = "2"
+
+SRC_URI = "https://lttng.org/files/lttng-ust/lttng-ust-${PV}.tar.bz2 \
+ file://lttng-ust-doc-examples-disable.patch \
+ "
+SRC_URI[md5sum] = "a95333f76e2986113154b8193f5cfca3"
+SRC_URI[sha256sum] = "c4ca22b904eb08817b313a73d499e1b217ffee1f862156d0d52865317486c045"
+
+CVE_PRODUCT = "ust"
+
+PACKAGECONFIG[manpages] = "--enable-man-pages, --disable-man-pages, asciidoc-native xmlto-native libxslt-native"
+
+do_install_append() {
+ # Patch python tools to use Python 3; they should be source compatible, but
+ # still refer to Python 2 in the shebang
+ sed -i -e '1s,#!.*python.*,#!${bindir}/python3,' ${D}${bindir}/lttng-gen-tp
+}