aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-modules_2.10.9.bb
diff options
context:
space:
mode:
authorJonathan Rajotte-Julien <jonathan.rajotte-julien@efficios.com>2019-03-13 20:55:54 +0000
committerArmin Kuster <akuster808@gmail.com>2019-03-22 14:40:46 -0700
commitb565ec33b908542b26527f3301672b4e3af6544c (patch)
tree966793b95f83cd9b3505ea0f5bfafaeb218f2ccf /meta/recipes-kernel/lttng/lttng-modules_2.10.9.bb
parent13cc1e7a9cd58b35044f8474b5b8601ea63b03f4 (diff)
downloadopenembedded-core-contrib-b565ec33b908542b26527f3301672b4e3af6544c.tar.gz
lttng-modules: update to 2.10.9
Drop patch [1] since it is part of the 2.10.9 release. [1] lttng-modules/0001-Fix-net-expose-sk-wmem-in-sock_exceed_buf_limit-trac.patch Signed-off-by: Jonathan Rajotte <jonathan.rajotte-julien@efficios.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-modules_2.10.9.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.10.9.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.10.9.bb b/meta/recipes-kernel/lttng/lttng-modules_2.10.9.bb
new file mode 100644
index 0000000000..d297377755
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.10.9.bb
@@ -0,0 +1,36 @@
+SECTION = "devel"
+SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
+DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
+LICENSE = "LGPLv2.1 & GPLv2 & MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c4613d1f8a9587bd7b366191830364b3 \
+ file://gpl-2.0.txt;md5=751419260aa954499f7abaabaa882bbe \
+ file://lgpl-2.1.txt;md5=243b725d71bb5df4a1e5920b344b86ad \
+ "
+
+inherit module
+
+COMPATIBLE_HOST = '(x86_64|i.86|powerpc|aarch64|mips|nios2|arm).*-linux'
+
+#https://lttng.org/files/lttng-modules/lttng-modules-2.10.7.tar.bz2
+SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \
+ file://Makefile-Do-not-fail-if-CONFIG_TRACEPOINTS-is-not-en.patch \
+ file://BUILD_RUNTIME_BUG_ON-vs-gcc7.patch \
+"
+
+SRC_URI[md5sum] = "09df0ac2e8f245740a2f32411d10c0d1"
+SRC_URI[sha256sum] = "a1855bbd02d0f71ebd180e9872309862036624f012442ab9cc5852eb60340145"
+
+export INSTALL_MOD_DIR="kernel/lttng-modules"
+
+EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'"
+
+do_install_append() {
+ # Delete empty directories to avoid QA failures if no modules were built
+ find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \;
+}
+
+python do_package_prepend() {
+ if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')):
+ bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN'))
+}
+