aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2015-01-26 13:19:10 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-02-08 08:00:30 +0000
commit46b1b96324d9cef5b1d9664a5990d0e7b82c5302 (patch)
treeb7c4c840784acbddc9f84a4c81ee58486752988c /meta/recipes-kernel/linux
parentef3fa6011b6c42ea2a3cd05b980895293724da77 (diff)
downloadopenembedded-core-contrib-46b1b96324d9cef5b1d9664a5990d0e7b82c5302.tar.gz
linux-yocto: basic octeon III support
Importing the following commits to add basic octeon III support to the 3.14 linux-yocto kernel: 1e0bbd1dd68e MIPS:OCTEON: More OCTEONIII support f51a5843ee2d MIPS: Octeon: CVMSEG LM loads may cause dcache parity errors 58bcba842781 MIPS: Octeon: Implement the core-16057 workaround ba5a219685e8 MIPS Override assembler ISA for kernel FPU instruction. 7759a0511965 MIPS donot build fast TLB refill handler with 32-bit kernels. 3f51e46ff641 MIPS Add minimal support for OCTEON3 to c-r4k.c bbde024d903a MIPS Add function get ebase cpunum 9f18310679cb MIPS OCTEON Enable use of FPU d24496ee8fc8 MIPS OCTEON Add OCTEON3 to get cpu type (From OE-Core rev: 451142572f156ff0e88943931b924bfb0d9c30ce) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_3.14.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.14.bb16
3 files changed, 11 insertions, 11 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_3.14.bb b/meta/recipes-kernel/linux/linux-yocto-rt_3.14.bb
index fbd331f38e..342debe2c9 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_3.14.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_3.14.bb
@@ -3,8 +3,8 @@ KBRANCH_qemuppc ?= "standard/preempt-rt/qemuppc"
require recipes-kernel/linux/linux-yocto.inc
-SRCREV_machine ?= "367c3b9712a6e469aed0cb5deebd5d3bfab12b79"
-SRCREV_machine_qemuppc ?= "4e827a9b658b6381f6706490e40b6a069a0c4b64"
+SRCREV_machine ?= "c9291eb73e9729480c651cca73babdb29e193ad4"
+SRCREV_machine_qemuppc ?= "35bfb41271634b66522164efeb424822993899c7"
SRCREV_meta ?= "6eddbf47875ef48ddc5864957a7b63363100782b"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.14.git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb
index 2d1bc21171..0808d1bf1a 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb
@@ -8,7 +8,7 @@ LINUX_VERSION ?= "3.14.29"
KMETA = "meta"
-SRCREV_machine ?= "21ba402e0a5286baf0b8960da132e2d56f020c88"
+SRCREV_machine ?= "1e0bbd1dd68e255a9af7c36930debc6dd4885d0c"
SRCREV_meta ?= "6eddbf47875ef48ddc5864957a7b63363100782b"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.14.bb b/meta/recipes-kernel/linux/linux-yocto_3.14.bb
index f218a91b48..19b7c126ba 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.14.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.14.bb
@@ -11,14 +11,14 @@ KBRANCH_qemux86 ?= "standard/common-pc/base"
KBRANCH_qemux86-64 ?= "standard/common-pc-64/base"
KBRANCH_qemumips64 ?= "standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "c0ed33beda334dcd387dff89da9804c03e24d648"
-SRCREV_machine_qemuarm64 ?= "21ba402e0a5286baf0b8960da132e2d56f020c88"
-SRCREV_machine_qemumips ?= "808071c5f72dc98ed2192de28bdd4e9ba2f7e820"
-SRCREV_machine_qemuppc ?= "0f93713ce91cc93f055ae6bcf1bf728d4036d097"
-SRCREV_machine_qemux86 ?= "f6aa7aaca80e8532316bfb6e8dd2fbf9ab4f8b8e"
-SRCREV_machine_qemux86-64 ?= "21ba402e0a5286baf0b8960da132e2d56f020c88"
-SRCREV_machine_qemumips64 ?= "f44eb151dc53822f4f94f50b2ec67a0a1aab041b"
-SRCREV_machine ?= "21ba402e0a5286baf0b8960da132e2d56f020c88"
+SRCREV_machine_qemuarm ?= "4af8557eb8576ba957980705a3719aca0e27836e"
+SRCREV_machine_qemuarm64 ?= "1e0bbd1dd68e255a9af7c36930debc6dd4885d0c"
+SRCREV_machine_qemumips ?= "520d5d89434c61b4a95ac0c68d8e74fc8068e35b"
+SRCREV_machine_qemuppc ?= "73e4399fd8db810cb59423767f9ca82a54311c7b"
+SRCREV_machine_qemux86 ?= "19e871b55f80d4cbd406b64d3d5fabf6103e6f1c"
+SRCREV_machine_qemux86-64 ?= "1e0bbd1dd68e255a9af7c36930debc6dd4885d0c"
+SRCREV_machine_qemumips64 ?= "6a469761ad8b3a0e585e53b842ea8d55d05089e3"
+SRCREV_machine ?= "1e0bbd1dd68e255a9af7c36930debc6dd4885d0c"
SRCREV_meta ?= "6eddbf47875ef48ddc5864957a7b63363100782b"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.14.git;bareclone=1;branch=${KBRANCH},${KMETA};name=machine,meta"