aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2015-02-18 22:10:22 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-02-20 18:16:53 +0000
commit329a028bec428e8dc8cf3420c6e462de2898c8aa (patch)
tree1049838b623a4bca09bed1753f3944f933b75aad /meta/recipes-kernel/linux
parent19203a95f4b65e0a009a738fb4fc216e985a0835 (diff)
downloadopenembedded-core-contrib-329a028bec428e8dc8cf3420c6e462de2898c8aa.tar.gz
linux-yocto: introduce 3.19 versioned recipes
Introducing the v3.19.x recipes for the validated linux-yocto kernel. Build, boot and sanity testing was performed on qemu for all major architectures. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta/recipes-kernel/linux')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_3.19.bb21
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.19.bb39
2 files changed, 60 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_3.19.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_3.19.bb
new file mode 100644
index 0000000000..dba163e006
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_3.19.bb
@@ -0,0 +1,21 @@
+KBRANCH ?= "standard/tiny/base"
+LINUX_KERNEL_TYPE = "tiny"
+KCONFIG_MODE = "--allnoconfig"
+
+require recipes-kernel/linux/linux-yocto.inc
+
+LINUX_VERSION ?= "3.19"
+
+KMETA = "meta"
+
+SRCREV_machine ?= "43b9eced9ba8a57add36af07736344dcc383f711"
+SRCREV_meta ?= "8897ef68b30e7426bc1d39895e71fb155d694974"
+
+PV = "${LINUX_VERSION}+git${SRCPV}"
+
+SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.19.git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
+
+COMPATIBLE_MACHINE = "(qemux86)"
+
+# Functionality flags
+KERNEL_FEATURES = ""
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.19.bb b/meta/recipes-kernel/linux/linux-yocto_3.19.bb
new file mode 100644
index 0000000000..044ee7f524
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto_3.19.bb
@@ -0,0 +1,39 @@
+KBRANCH ?= "standard/base"
+
+require recipes-kernel/linux/linux-yocto.inc
+
+# board specific branches
+KBRANCH_qemuarm ?= "standard/arm-versatile-926ejs"
+KBRANCH_qemuarm64 ?= "standard/qemuarm64"
+KBRANCH_qemumips ?= "standard/mti-malta32"
+KBRANCH_qemuppc ?= "standard/qemuppc"
+KBRANCH_qemux86 ?= "standard/common-pc"
+KBRANCH_qemux86-64 ?= "standard/common-pc-64/base"
+KBRANCH_qemumips64 ?= "standard/mti-malta64"
+
+SRCREV_machine_qemuarm ?= "91b64df8cdcdacb9ef8d707a0c34f55a09bf170d"
+SRCREV_machine_qemuarm64 ?= "43b9eced9ba8a57add36af07736344dcc383f711"
+SRCREV_machine_qemumips ?= "7c67469a4c77a977c46f218de7e2f4699292d28b"
+SRCREV_machine_qemuppc ?= "7dc29d4265b44ad28ea3ec950b1a86be08933ce8"
+SRCREV_machine_qemux86 ?= "43b9eced9ba8a57add36af07736344dcc383f711"
+SRCREV_machine_qemux86-64 ?= "43b9eced9ba8a57add36af07736344dcc383f711"
+SRCREV_machine_qemumips64 ?= "b7ab9d4bac55415f125c81f529dbbefb07de98ad"
+SRCREV_machine ?= "43b9eced9ba8a57add36af07736344dcc383f711"
+SRCREV_meta ?= "8897ef68b30e7426bc1d39895e71fb155d694974"
+
+SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.19.git;bareclone=1;branch=${KBRANCH},${KMETA};name=machine,meta"
+
+LINUX_VERSION ?= "3.19"
+
+PV = "${LINUX_VERSION}+git${SRCPV}"
+
+KMETA = "meta"
+
+COMPATIBLE_MACHINE = "qemuarm|qemuarm64|qemux86|qemuppc|qemumips|qemumips64|qemux86-64"
+
+# Functionality flags
+KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc"
+KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}"
+KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
+KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc cfg/paravirt_kvm.scc"
+KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}"