aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_git.bb
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@intel.com>2011-01-14 16:33:05 -0600
committerSaul Wold <sgw@linux.intel.com>2011-01-14 15:18:10 -0800
commitd38ad3271829b2d282c973e69edd265ef52174c8 (patch)
tree845ec061bf400088ae6e8cbc97bbce480a245779 /meta/recipes-kernel/linux/linux-yocto_git.bb
parent9c6b313acb500095fa80a8c57e27a55d3c34797f (diff)
downloadopenembedded-core-contrib-d38ad3271829b2d282c973e69edd265ef52174c8.tar.gz
linux-yocto: hard-code NO_LIBPERL/NO_LIBPYTHON
ExtUtils::Embed ccopts is getting the host's -I/usr/local/include and using it to compile perf, which results in a compilation error that started appearing just recently. This turns the code that makes use of ExtUtils::Embed off and simply hard-codes NO_LIBPERL. It does the same for LIBPYTHON while we're at it, since it probably suffers from a similar underlying problem and just by chance hasn't broken anything yet. This will be re-enabled after I familiarize myself with the perf recipe and am able to create a proper fix. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_git.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_git.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_git.bb b/meta/recipes-kernel/linux/linux-yocto_git.bb
index 21023da54b..7833f65fa4 100644
--- a/meta/recipes-kernel/linux/linux-yocto_git.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_git.bb
@@ -13,12 +13,13 @@ KMACHINE_beagleboard = "yocto/standard/beagleboard"
LINUX_VERSION ?= "2.6.37"
LINUX_VERSION_EXTENSION ?= "-yocto-${LINUX_KERNEL_TYPE}"
-PR = "r14"
+PR = "r15"
PV = "${LINUX_VERSION}+git${SRCPV}"
SRCREV_FORMAT = "meta_machine"
SRC_URI = "git://git.pokylinux.org/linux-yocto-2.6.37;protocol=git;fullclone=1;branch=${KBRANCH};name=machine \
- git://git.pokylinux.org/linux-yocto-2.6.37;protocol=git;noclone=1;branch=meta;name=meta"
+ git://git.pokylinux.org/linux-yocto-2.6.37;protocol=git;noclone=1;branch=meta;name=meta \
+ file://tools-perf-no-scripting.patch"
COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64|mpc8315e-rdb|routerstationpro)"