aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_4.14.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2018-06-06 22:07:24 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-06-08 11:11:22 +0100
commiteed723d09992c9b89fcb2760f8c95f69c201aa3c (patch)
treef7478410e75fea6c5eba9d5d0fa80afe1a1171db /meta/recipes-kernel/linux/linux-yocto_4.14.bb
parent7dd52d9e39109d8b24227163857595f17be16f4d (diff)
downloadopenembedded-core-contrib-eed723d09992c9b89fcb2760f8c95f69c201aa3c.tar.gz
linux-yocto/4.14/4.15: gcc8 fixes
Integrating Khem's gcc8 kernel patches so that 4.14 and 4.15 can build with the gcc8 compiler updates. 51273ff79f4a tools/lib/subcmd/pager.c: do not alias select() params b632c05a6263 objtool, perf: Fix GCC 8 -Wrestrict error 20bc5eb24ac1 mips64: Disable attribute-alias warning 975042cc72dd mips: Disable attribute-alias warnings 8632f470f02c powerpc/ptrace: Disable array-bounds warning with gcc8 59e401ffeda4 powerpc: Disable attribute-alias warnings from gcc8 Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_4.14.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.14.bb18
1 files changed, 9 insertions, 9 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.14.bb b/meta/recipes-kernel/linux/linux-yocto_4.14.bb
index 28812484dd..c8f31a6ebc 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.14.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.14.bb
@@ -11,15 +11,15 @@ KBRANCH_qemux86 ?= "v4.14/standard/base"
KBRANCH_qemux86-64 ?= "v4.14/standard/base"
KBRANCH_qemumips64 ?= "v4.14/standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "0270dc3fc64e8df96067a5cc0d3cdcc7da448967"
-SRCREV_machine_qemuarm64 ?= "cc01b6df5e42a636339020123f9e36e76feb217a"
-SRCREV_machine_qemumips ?= "7100705d087727cec0f353b430910dbd56c0b14f"
-SRCREV_machine_qemuppc ?= "9e2c25e06bd9b9c799c0c7103566d587fdd16858"
-SRCREV_machine_qemux86 ?= "3a3979936c8a3b70488af80a7dcadd41e2480603"
-SRCREV_machine_qemux86-64 ?= "3a3979936c8a3b70488af80a7dcadd41e2480603"
-SRCREV_machine_qemumips64 ?= "149f8eee22d52a287994c1d0c54d4d37631629ef"
-SRCREV_machine ?= "3a3979936c8a3b70488af80a7dcadd41e2480603"
-SRCREV_meta ?= "0a24859cef9c3352aa3bf153d202cece587caf24"
+SRCREV_machine_qemuarm ?= "493254190708d94e0bd22f6eb6e6c17cbdbf9764"
+SRCREV_machine_qemuarm64 ?= "eeba95930402de2c0290b423c69e86b84955bf09"
+SRCREV_machine_qemumips ?= "42b5e2db78595024d2fddfcadc8cd8af1266b52b"
+SRCREV_machine_qemuppc ?= "b87ce52358105e318fbdb7087185de9622b420b3"
+SRCREV_machine_qemux86 ?= "0e21580445573276ec320da0c36d56f8921f682b"
+SRCREV_machine_qemux86-64 ?= "0e21580445573276ec320da0c36d56f8921f682b"
+SRCREV_machine_qemumips64 ?= "c8885bcf579812bd6cfbb58b96d5d3423ccc45fc"
+SRCREV_machine ?= "0e21580445573276ec320da0c36d56f8921f682b"
+SRCREV_meta ?= "d1e170692e978b08f4736375cafccd58e331feb1"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;name=machine;branch=${KBRANCH}; \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.14;destsuffix=${KMETA}"