aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_4.14.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2018-06-11 12:11:22 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-06-11 23:38:17 +0100
commit8ab5b439ea82ac775494a0ce7a6f3615b61c94be (patch)
tree14e2d79aae8dc36552567d2ab4e543237734f39e /meta/recipes-kernel/linux/linux-yocto_4.14.bb
parent69e2b2ce2f499058d48a3b35febc757247e9df69 (diff)
downloadopenembedded-core-contrib-8ab5b439ea82ac775494a0ce7a6f3615b61c94be.tar.gz
linux-yocto/4.14/4.15: fix gcc8 mips compilation issues
Making the following commit available to fix mips gcc8 build issues: commit e25dbfe95302eeaa1a03a828d05c09479574488a Author: Kevin Hao <kexin.hao@windriver.com> Date: Mon Jun 11 18:17:54 2018 +0800 MIPS: Use '+=" instead of '=' to avoid the CFLAGS override We used the CFLAGS_xxx to workaround the gcc 8 build warnings for some specific file. But CFLAGS_xxx is also used with '=' in other places of this Makefile. This override the gcc 8 workaround, so replace all the '=' with '+=" to fix this issue. Signed-off-by: Kevin Hao <kexin.hao@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Kevin Hao <kexin.hao@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_4.14.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.14.bb16
1 files changed, 8 insertions, 8 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.14.bb b/meta/recipes-kernel/linux/linux-yocto_4.14.bb
index 12cd8254e0..0449213d42 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.14.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.14.bb
@@ -11,14 +11,14 @@ KBRANCH_qemux86 ?= "v4.14/standard/base"
KBRANCH_qemux86-64 ?= "v4.14/standard/base"
KBRANCH_qemumips64 ?= "v4.14/standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "3a7b21b8959eaeb6b3548ccc03e5aeef02757a83"
-SRCREV_machine_qemuarm64 ?= "fff23f8dabf7774db37656037243f5706f311ccd"
-SRCREV_machine_qemumips ?= "825a9302d4829384c5f8ccdf96a71f39441095dd"
-SRCREV_machine_qemuppc ?= "24febbcbc2cefbf05ea038ed1042603142d3b033"
-SRCREV_machine_qemux86 ?= "2bf00ed1aee9c26b48c26b10c731c2f8970d50c2"
-SRCREV_machine_qemux86-64 ?= "2bf00ed1aee9c26b48c26b10c731c2f8970d50c2"
-SRCREV_machine_qemumips64 ?= "a55b95ebad77a4124d5f52a6d121d59e17647289"
-SRCREV_machine ?= "2bf00ed1aee9c26b48c26b10c731c2f8970d50c2"
+SRCREV_machine_qemuarm ?= "363723ef50c06df54e146c8fe78faa962e96a8c8"
+SRCREV_machine_qemuarm64 ?= "798d15552a4d5d9355a300290ed6bf72106b7e96"
+SRCREV_machine_qemumips ?= "6c2433d7c51c3e78b1be2c7d1fbfe840b13d04df"
+SRCREV_machine_qemuppc ?= "c03babad17499489b20216576d608c94e7fddc5d"
+SRCREV_machine_qemux86 ?= "65d1c849534179bbfa494f77947f8be615e9871a"
+SRCREV_machine_qemux86-64 ?= "65d1c849534179bbfa494f77947f8be615e9871a"
+SRCREV_machine_qemumips64 ?= "59f70381cbde371e41206b7902390ae78558c310"
+SRCREV_machine ?= "65d1c849534179bbfa494f77947f8be615e9871a"
SRCREV_meta ?= "94457657b8d621868672917d1c2631df4a4fadd8"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;name=machine;branch=${KBRANCH}; \