aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_3.8.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-02-25 03:51:34 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-02 22:43:33 +0000
commitecf287a80c5ace2c440f8d0089934d59d25dc3ec (patch)
tree89f34856d0e48b738ff8fb5badfa7fdd064f7e9d /meta/recipes-kernel/linux/linux-yocto_3.8.bb
parent4f9ef639143d890e9d2e71fea3b461fcc8e3f678 (diff)
downloadopenembedded-core-contrib-ecf287a80c5ace2c440f8d0089934d59d25dc3ec.tar.gz
linux-yocto: introduce 3.8 kernel recipe
Introducing the linux-yocto 3.8 kernel recipe. The tools and branch structure of this tree are the same as the previous linux-yocto recipes, while the meta data and content have been updated for the 3.8 kernel. build and boot tested for qemu*. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_3.8.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.8.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.8.bb b/meta/recipes-kernel/linux/linux-yocto_3.8.bb
new file mode 100644
index 0000000000..7c1dff768f
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto_3.8.bb
@@ -0,0 +1,30 @@
+require recipes-kernel/linux/linux-yocto.inc
+
+KBRANCH_DEFAULT = "standard/base"
+KBRANCH = "${KBRANCH_DEFAULT}"
+
+SRCREV_machine_qemuarm ?= "351d133943b50a9dfeee07661d44254722a19f04"
+SRCREV_machine_qemumips ?= "d529d082041142435587bd442b1235dbe1c72950"
+SRCREV_machine_qemuppc ?= "8dcd155ad408658e9180d1630da2ac7e0ee70542"
+SRCREV_machine_qemux86 ?= "b170394a475b96ecc92cbc9e4b002bed0a9f69c5"
+SRCREV_machine_qemux86-64 ?= "b170394a475b96ecc92cbc9e4b002bed0a9f69c5"
+SRCREV_machine ?= "b170394a475b96ecc92cbc9e4b002bed0a9f69c5"
+SRCREV_meta ?= "c2ed0f16fdec628242a682897d5d86df4547cf24"
+
+SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.8.git;protocol=git;bareclone=1;branch=${KBRANCH},${KMETA};name=machine,meta"
+
+LINUX_VERSION ?= "3.8"
+
+PR = "${INC_PR}.0"
+PV = "${LINUX_VERSION}+git${SRCPV}"
+
+KMETA = "meta"
+
+COMPATIBLE_MACHINE = "qemuarm|qemux86|qemuppc|qemumips|qemux86-64"
+
+# Functionality flags
+KERNEL_FEATURES_append = " features/netfilter/netfilter.scc"
+KERNEL_FEATURES_append_qemux86=" cfg/sound.scc"
+KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc"
+KERNEL_FEATURES_append_qemux86=" cfg/paravirt_kvm.scc"
+KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}"