aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_3.4.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-07-15 00:12:05 -0400
committerSaul Wold <sgw@linux.intel.com>2013-07-18 12:21:13 -0700
commit5cd0d0f0e19b53a002feb91ba0cde9ea7ec19f29 (patch)
treee91ca2b5818c9d11b8e7a76a8837885de0aee472 /meta/recipes-kernel/linux/linux-yocto_3.4.bb
parent0fabe26eabff716909b6c241fcb5b4cc7b78ceac (diff)
downloadopenembedded-core-contrib-5cd0d0f0e19b53a002feb91ba0cde9ea7ec19f29.tar.gz
linux-yocto/3.4: mips: fix gcc 4.8 compilation
Updating the SRCREVs to enable the following fix for gcc 4.8 mips compilation: Author: Steven J. Hill <sjhill@mips.com> Date: Fri Jul 6 21:56:01 2012 +0200 MIPS: Refactor 'clear_page' and 'copy_page' functions. Remove usage of the '__attribute__((alias("...")))' hack that aliased to integer arrays containing micro-assembled instructions. This hack breaks when building a microMIPS kernel. It also makes the code much easier to understand. [ralf@linux-mips.org: Added back export of the clear_page and copy_page symbols so certain modules will work again. Also fixed build with CONFIG_SIBYTE_DMA_PAGEOPS enabled.] Signed-off-by: Steven J. Hill <sjhill@mips.com> Cc: linux-mips@linux-mips.org Patchwork: https://patchwork.linux-mips.org/patch/3866/ Acked-by: David Daney <david.daney@cavium.com> Signed-off-by: Ralf Baechle <ralf@linux-mips.org> (cherry picked from commit c022630633624a75b3b58f43dd3c6cc896a56cff) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_3.4.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.4.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.4.bb b/meta/recipes-kernel/linux/linux-yocto_3.4.bb
index beb67ee49c..8db015ad01 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.4.bb
@@ -3,12 +3,12 @@ require recipes-kernel/linux/linux-yocto.inc
KBRANCH_DEFAULT = "standard/base"
KBRANCH = "${KBRANCH_DEFAULT}"
-SRCREV_machine_qemuarm ?= "89c1e24271fba1c235959cb96c91dba98c542821"
-SRCREV_machine_qemumips ?= "99e87eb8b1e985eb6addf7590c4e837ff7c7e873"
-SRCREV_machine_qemuppc ?= "62f5c50609c93c5b70736a4374cee8075ab82566"
-SRCREV_machine_qemux86 ?= "cdd7a546922ca1c46c94adeec3b9c90dc9aaad2d"
-SRCREV_machine_qemux86-64 ?= "cdd7a546922ca1c46c94adeec3b9c90dc9aaad2d"
-SRCREV_machine ?= "cdd7a546922ca1c46c94adeec3b9c90dc9aaad2d"
+SRCREV_machine_qemuarm ?= "a3bd53305c7dcd11a2683fbe5d830d44236f4cd4"
+SRCREV_machine_qemumips ?= "e142ba98038a697e3a96b8f30a16e93602eff3c7"
+SRCREV_machine_qemuppc ?= "290c3dd687145104d4e3f0e7732669c1c42b19fe"
+SRCREV_machine_qemux86 ?= "4122d6cf3f9e1fd6d54f6e13af29c4c589289fdc"
+SRCREV_machine_qemux86-64 ?= "4122d6cf3f9e1fd6d54f6e13af29c4c589289fdc"
+SRCREV_machine ?= "4122d6cf3f9e1fd6d54f6e13af29c4c589289fdc"
SRCREV_meta ?= "7250de4d4afc2558082cd42b8a0d151903436e8f"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.4.git;protocol=git;bareclone=1;branch=${KBRANCH},${KMETA};name=machine,meta"