aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_3.14.bb
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2014-12-18 16:51:15 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-22 10:53:56 +0000
commitaf67a2938e007e08fd1d082a0932c78deaedb527 (patch)
tree11b718df5fdb95fc1cad638f2ccc84af58ae5355 /meta/recipes-kernel/linux/linux-yocto_3.14.bb
parent03d2f5646485b565cc14a0009b7d5224ab298f4c (diff)
downloadopenembedded-core-contrib-af67a2938e007e08fd1d082a0932c78deaedb527.tar.gz
linux-yocto: Fixup linux-yocto for aarch64
linux-yocto is updated to pass the sysroot path to the compiler when necessary. linux-yocto_ver.bb are updated to reference the correct linux-yocto branchs and SRCREVs. Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_3.14.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.14.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.14.bb b/meta/recipes-kernel/linux/linux-yocto_3.14.bb
index 706cb7ce9c..5f0a09e973 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.14.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.14.bb
@@ -4,6 +4,7 @@ require recipes-kernel/linux/linux-yocto.inc
# board specific branches
KBRANCH_qemuarm ?= "standard/arm-versatile-926ejs"
+KBRANCH_qemuarm64 ?= "standard/qemuarm64"
KBRANCH_qemumips ?= "standard/mti-malta32"
KBRANCH_qemuppc ?= "standard/qemuppc"
KBRANCH_qemux86 ?= "standard/common-pc/base"
@@ -11,6 +12,7 @@ KBRANCH_qemux86-64 ?= "standard/common-pc-64/base"
KBRANCH_qemumips64 ?= "standard/mti-malta64"
SRCREV_machine_qemuarm ?= "6166316d47b859aa38bfecc61f4808828af03937"
+SRCREV_machine_qemuarm64 ?= "902f34d36102a4b2008b776ecae686f80d307e12"
SRCREV_machine_qemumips ?= "4ececcc09c6550a0896728163907e729d817c2fd"
SRCREV_machine_qemuppc ?= "1cc5b09f8bb7f40b289d149d370c62dcc8109501"
SRCREV_machine_qemux86 ?= "38cd560d5022ed2dbd1ab0dca9642e47c98a0aa1"
@@ -27,7 +29,7 @@ PV = "${LINUX_VERSION}+git${SRCPV}"
KMETA = "meta"
-COMPATIBLE_MACHINE = "qemuarm|qemux86|qemuppc|qemumips|qemumips64|qemux86-64"
+COMPATIBLE_MACHINE = "qemuarm|qemuarm64|qemux86|qemuppc|qemumips|qemumips64|qemux86-64"
# Functionality flags
KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc"