aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_3.14.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-08-20 12:21:27 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-23 23:01:58 +0100
commit321cb592efafb8ccfb48fc58d83eb9797b75143c (patch)
tree1538a67599c634f08dea710bb40fb213171d6161 /meta/recipes-kernel/linux/linux-yocto_3.14.bb
parent2ffbc2729ab2f6a31d58b1a0bd355b8f67f8ba85 (diff)
downloadopenembedded-core-contrib-321cb592efafb8ccfb48fc58d83eb9797b75143c.tar.gz
linux-yocto/3.14: add ARM kprobes support
Adding the following commits to the 3.14 tree for ARM kprobe support: c1750e55eb75 ARM: add uprobes support 33e8a1334afe ARM: Make arch_specific_insn a define for new arch_probes_insn structure b1d3feead083 ARM: Add an emulate flag to the kprobes/uprobes instruction decode functions 84b5b70a01a2 ARM: Change the remaining shared kprobes/uprobes symbols to something generic 624e5e9aab5a ARM: Rename the shared kprobes/uprobe return value enum 7741eac39c2e ARM: Change more ARM kprobes symbol names to something more generic 47f51bac6a2d ARM: Make the kprobes condition_check symbol names more generic 3af2f454bb8e ARM: Remove use of struct kprobe from generic probes code a31964d3143a ARM: use a function table for determining instruction interpreter action 6de77767abfc ARM: move generic thumb instruction parsing code to new files for use by other feature eb2db188b856 ARM: Move generic arm instruction parsing code to new files for sharing between features bbc0a43ff46e ARM: move shared uprobe/kprobe definitions into new include file f5f2896020e6 uprobes: allow ignoring of probe hits cb133db6bd60 ARM: Fix missing includes in kprobes sources (From OE-Core rev: 835bb10d07d1a64119379e9837dd853dacfe79bc) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_3.14.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.14.bb14
1 files changed, 7 insertions, 7 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.14.bb b/meta/recipes-kernel/linux/linux-yocto_3.14.bb
index 1e397e9026..52ba9336dc 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.14.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.14.bb
@@ -10,13 +10,13 @@ KBRANCH_qemux86 = "standard/common-pc/base"
KBRANCH_qemux86-64 = "standard/common-pc-64/base"
KBRANCH_qemumips64 = "standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "b38b84aebf889d84e65e81ac11122b977f0c5155"
-SRCREV_machine_qemumips ?= "c9d827207d8dfab330787659b2842485dbd36d77"
-SRCREV_machine_qemuppc ?= "58b7cb00580985410ba8491c61e80d2572552ed9"
-SRCREV_machine_qemux86 ?= "5b327970eb1dba02c65cb8330dc8f3049c4fa580"
-SRCREV_machine_qemux86-64 ?= "5724bf17acbf54cf61003ab242448fd96d189384"
-SRCREV_machine_qemumips64 ?= "34837892b66eaa034cd3e3d339cab0ea6f594511"
-SRCREV_machine ?= "5724bf17acbf54cf61003ab242448fd96d189384"
+SRCREV_machine_qemuarm ?= "b91ab4c1bf0dccef4c93aeb184fca3a933682ba0"
+SRCREV_machine_qemumips ?= "1fdf6bfb5ecefccddead6e1d53b6e19d52da092e"
+SRCREV_machine_qemuppc ?= "8a44bd5e4fca2260d2e24e2cb4a5f276d000fae8"
+SRCREV_machine_qemux86 ?= "984636272f33a48803e1b0f8f48553894306b4e2"
+SRCREV_machine_qemux86-64 ?= "c1750e55eb751d4773ea4c3e924e1858feb15e4e"
+SRCREV_machine_qemumips64 ?= "a240524ebe0051faf7ada3cdb3241dda6d8d3ba3"
+SRCREV_machine ?= "c1750e55eb751d4773ea4c3e924e1858feb15e4e"
SRCREV_meta ?= "54d07ec2566afe2a4c1eee4995781aab5599b5d5"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.14.git;bareclone=1;branch=${KBRANCH},${KMETA};name=machine,meta"