aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_3.0.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2012-03-22 16:00:08 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-05-08 16:05:59 +0100
commit06e5f45c8f38925cd5902a3a3f436f5e9451dd16 (patch)
tree795f58cc521573abc8649cfae40930b569a84434 /meta/recipes-kernel/linux/linux-yocto_3.0.bb
parent612047a20ca400b932ccc634ddb759460d69fdce (diff)
downloadopenembedded-core-contrib-06e5f45c8f38925cd5902a3a3f436f5e9451dd16.tar.gz
linux-yocto: streamline support for multiple upstream repo types
In order to support repositories of various types (with or without meta data, branched, pristine, custom, etc) information about the type of processing that is required was passed to the processing phases via variables. The combination of variables involved in coordinating the processing creates a learning curve and overly complicates recipe extensions. With minor tweaks to the kern-tools, adding flexibility and keying off the existence of the meta branch it is possible to remove all of the variables that were added to support different repository types. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_3.0.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.0.bb23
1 files changed, 15 insertions, 8 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.0.bb b/meta/recipes-kernel/linux/linux-yocto_3.0.bb
index 074b1ede95..82a7224251 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.0.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.0.bb
@@ -1,14 +1,21 @@
inherit kernel
require recipes-kernel/linux/linux-yocto.inc
-KMACHINE = "yocto/standard/base"
-KMACHINE_qemux86 = "yocto/standard/common-pc/base"
-KMACHINE_qemux86-64 = "yocto/standard/common-pc-64/base"
-KMACHINE_qemuppc = "yocto/standard/qemu-ppc32"
-KMACHINE_qemumips = "yocto/standard/mti-malta32-be"
-KMACHINE_qemuarm = "yocto/standard/arm-versatile-926ejs"
-
-KBRANCH = "${KMACHINE}"
+KBRANCH = "yocto/standard/base"
+KBRANCH_qemux86 = "yocto/standard/common-pc/base"
+KBRANCH_qemux86-64 = "yocto/standard/common-pc-64/base"
+KBRANCH_qemuppc = "yocto/standard/qemu-ppc32"
+KBRANCH_qemumips = "yocto/standard/mti-malta32-be"
+KBRANCH_qemuarm = "yocto/standard/arm-versatile-926ejs"
+
+# Temporary until 3.0 kernel tree is updated with machine mappings
+KMACHINE_qemux86 = "common-pc"
+KMACHINE_qemux86-64 = "common-pc-64"
+KMACHINE_qemuppc = "qemu-ppc32"
+KMACHINE_qemumips = "mti-malta32-be"
+KMACHINE_qemuarm = "arm-versatile-926ejs"
+
+KMETA = "meta"
LINUX_VERSION ?= "3.0.24"