summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto
diff options
context:
space:
mode:
authorLiang Li <liang.li@windriver.com>2012-08-22 16:02:33 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-25 14:44:00 +0100
commit4e0daf05ed04e9fb4343032c6290a379f53b89f3 (patch)
tree50e7b3d44ea217eb6507485625651c20bba0a637 /meta/recipes-kernel/linux/linux-yocto
parent20e2aaacb36113604c4ea7c40dd0bbbf224b8360 (diff)
downloadopenembedded-core-contrib-4e0daf05ed04e9fb4343032c6290a379f53b89f3.tar.gz
kernel.bbclass: fix INC directory for SLANG
In the kernel's tools/perf/Makefile CFLAGS was previously hard coded to contain "-I/usr/include/slang" to work with hosts that have "/usr/include/slang/slang.h" as well as hosts that have "/usr/include/slang.h". This path can cause compile warnings like: cc1: warning: '/usr/include/slang' doesn't exists. or cc1: warning: include location "/usr/include/slang" is unsafe for cross-compilation [-Wpoison-system-directories] Then in some cases warnings become errors if WERROR is enabled hence build errors. In coordination with a kernel fix, we can fix this error for all kernels by modifying the perf Makefile within the staged kernel source. Signed-off-by: Liang Li <liang.li@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto/noslang.patch20
1 files changed, 0 insertions, 20 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto/noslang.patch b/meta/recipes-kernel/linux/linux-yocto/noslang.patch
deleted file mode 100644
index 9cada34d11..0000000000
--- a/meta/recipes-kernel/linux/linux-yocto/noslang.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-We (OE) install slang into /usr/include so we never need to look into
-/usr/include/slang/. We never want to look into a hardcoded path like this
-since it triggers host infection issues. For now, simply remove this
-since it causes us problems.
-
-Upstream-Status: Pending (would need rework)
-
-Index: tools/perf/Makefile
-===================================================================
---- linux.orig/tools/perf/Makefile 2012-08-07 10:29:43.020149620 +0000
-+++ linux/tools/perf/Makefile 2012-08-07 10:30:08.128148098 +0000
-@@ -504,7 +504,7 @@
- BASIC_CFLAGS += -DNO_NEWT_SUPPORT
- else
- # Fedora has /usr/include/slang/slang.h, but ubuntu /usr/include/slang.h
-- BASIC_CFLAGS += -I/usr/include/slang
-+ # BASIC_CFLAGS += -I/usr/include/slang
- EXTLIBS += -lnewt -lslang
- LIB_OBJS += $(OUTPUT)util/ui/setup.o
- LIB_OBJS += $(OUTPUT)util/ui/browser.o