summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto.inc
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2014-12-18 16:51:15 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-22 10:53:56 +0000
commitaf67a2938e007e08fd1d082a0932c78deaedb527 (patch)
tree11b718df5fdb95fc1cad638f2ccc84af58ae5355 /meta/recipes-kernel/linux/linux-yocto.inc
parent03d2f5646485b565cc14a0009b7d5224ab298f4c (diff)
downloadopenembedded-core-contrib-af67a2938e007e08fd1d082a0932c78deaedb527.tar.gz
linux-yocto: Fixup linux-yocto for aarch64
linux-yocto is updated to pass the sysroot path to the compiler when necessary. linux-yocto_ver.bb are updated to reference the correct linux-yocto branchs and SRCREVs. Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto.inc')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto.inc2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto.inc b/meta/recipes-kernel/linux/linux-yocto.inc
index 90189857c6..7416af99f5 100644
--- a/meta/recipes-kernel/linux/linux-yocto.inc
+++ b/meta/recipes-kernel/linux/linux-yocto.inc
@@ -8,6 +8,8 @@ INC_PR = "r4"
DEPENDS += "xz-native bc-native"
DEPENDS_append_aarch64 = " libgcc"
+KERNEL_CC_append_aarch64 = " ${TOOLCHAIN_OPTIONS}"
+KERNEL_LD_append_aarch64 = " ${TOOLCHAIN_OPTIONS}"
# A KMACHINE is the mapping of a yocto $MACHINE to what is built
# by the kernel. This is typically the branch that should be built,