aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto.inc
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2012-06-27 17:38:57 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-06-29 13:31:01 +0100
commit934bb7bbfcfeee4da556c7ea431ce4071583bc25 (patch)
treefbf9d8c57930bfbe1a121ecf6a6c4822909a3150 /meta/recipes-kernel/linux/linux-yocto.inc
parent11809e3fd1ae074c9ca002543c9c228f2db17784 (diff)
downloadopenembedded-core-contrib-934bb7bbfcfeee4da556c7ea431ce4071583bc25.tar.gz
linux-yocto: Use INC_PR and move kernel require to linux-yocto.inc
When making changes to kernel.bbclass, it would be nice not to have to manually change the PR of every linux-yocto*.bb file that requires it. Move the "require kernel" line to linux-yocto.inc and update the linux-yocto recipes to use INC_PR. (From OE-Core rev: 7a41d96c946029aeec03cd26f326bc6ca26e74fd) Signed-off-by: Darren Hart <dvhart@linux.intel.com> CC: Bruce Ashfield <bruce.ashfield@windriver.com> CC: Tom Zanussi <tom.zanussi@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto.inc')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto.inc3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto.inc b/meta/recipes-kernel/linux/linux-yocto.inc
index 0912beef5a..9b46e74531 100644
--- a/meta/recipes-kernel/linux/linux-yocto.inc
+++ b/meta/recipes-kernel/linux/linux-yocto.inc
@@ -4,6 +4,8 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
+INC_PR = "r3"
+
# A KMACHINE is the mapping of a yocto $MACHINE to what is built
# by the kernel. This is typically the branch that should be built,
# and it can be specific to the machine or shared
@@ -23,6 +25,7 @@ do_patch[depends] = "kern-tools-native:do_populate_sysroot"
addtask kernel_configme before do_configure after do_patch
# Pick up shared functions
+inherit kernel
inherit kernel-yocto
require linux-dtb.inc