aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-tiny_4.8.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2016-08-30 12:48:59 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-05 11:55:49 +0100
commit3585c71dc575dd28a1e2655efc967dd4d6086a37 (patch)
treea66d841a9a942373c0a2246d91ed1fbd54b87c30 /meta/recipes-kernel/linux/linux-yocto-tiny_4.8.bb
parent9b08503eabf78bc1b114416523b41dcce3449f58 (diff)
downloadopenembedded-core-contrib-3585c71dc575dd28a1e2655efc967dd4d6086a37.tar.gz
linux-yocto: introduce v4.8 recipes
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-tiny_4.8.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.8.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.8.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.8.bb
new file mode 100644
index 0000000000..a157c2aa80
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.8.bb
@@ -0,0 +1,23 @@
+KBRANCH ?= "standard/tiny/common-pc"
+LINUX_KERNEL_TYPE = "tiny"
+KCONFIG_MODE = "--allnoconfig"
+
+require recipes-kernel/linux/linux-yocto.inc
+
+LINUX_VERSION ?= "4.8-rc4"
+
+KMETA = "kernel-meta"
+KCONF_BSP_AUDIT_LEVEL = "2"
+
+SRCREV_machine ?= "3eab887a55424fc2c27553b7bfe32330df83f7b8"
+SRCREV_meta ?= "8cb7317502c2577f8c83eaf1c061603023824313"
+
+PV = "${LINUX_VERSION}+git${SRCPV}"
+
+SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.8.git;branch=${KBRANCH};name=machine \
+ git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.8;destsuffix=${KMETA}"
+
+COMPATIBLE_MACHINE = "(qemux86$)"
+
+# Functionality flags
+KERNEL_FEATURES = ""