aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-tiny_4.15.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2018-07-09 11:25:34 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-09 23:01:39 +0100
commit9e88c4923a337ca8279feaa773884a9c26a092f3 (patch)
treeaed23ef1bf81bb7a9b0fb5f06cf69ac3e4e0331d /meta/recipes-kernel/linux/linux-yocto-tiny_4.15.bb
parent1c31fa6929fc97e2fb0c4fbfcc66c789c39c1117 (diff)
downloadopenembedded-core-contrib-9e88c4923a337ca8279feaa773884a9c26a092f3.tar.gz
linux-yocto: add qemuarm -tiny support
Adding a BSP definition to the kernel-cache, creating a tiny branch for board specific patches and finally setting the machine compatibility in the linux-yocto-tiny recipe. This is only the BSP definition and kernel configuration side of things, more changes are necessary for full tiny distro support on qemumarm. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-tiny_4.15.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.15.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.15.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.15.bb
index 5f9b3c7fb3..8bad903eff 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_4.15.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.15.bb
@@ -1,4 +1,5 @@
KBRANCH ?= "v4.15/standard/tiny/common-pc"
+KBRANCH_qemuarm ?= "v4.15/standard/tiny/arm-versatile-926ejs"
LINUX_KERNEL_TYPE = "tiny"
KCONFIG_MODE = "--allnoconfig"
@@ -9,15 +10,15 @@ LINUX_VERSION ?= "4.15.18"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine ?= "e25dbfe95302eeaa1a03a828d05c09479574488a"
-SRCREV_meta ?= "45c256a5ca6f9478bce212fec19e2bc273472631"
+SRCREV_machine ?= "3373c0cf71f2812eeb9694839456df6f67fd32ac"
+SRCREV_meta ?= "ff65711e13fa39d7fe2947a1ba196dad82eed327"
PV = "${LINUX_VERSION}+git${SRCPV}"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.15;destsuffix=${KMETA}"
-COMPATIBLE_MACHINE = "qemux86|qemux86-64"
+COMPATIBLE_MACHINE = "qemux86|qemux86-64|qemuarm"
# Functionality flags
KERNEL_FEATURES = ""