aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-tiny_4.10.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2017-02-26 22:10:02 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-03 12:21:10 +0000
commite8f07d2966a3fc6cfc6466020dc6603a84fe33da (patch)
tree03a4bb63bb22d5bc392a52fcc7cd3a3f4ae9c596 /meta/recipes-kernel/linux/linux-yocto-tiny_4.10.bb
parent20c6e876ed6b8c8ac007848e2b36e9a8a56bb703 (diff)
downloadopenembedded-core-contrib-e8f07d2966a3fc6cfc6466020dc6603a84fe33da.tar.gz
linux-yocto: introduce 4.10 recipes
The 4.10 kernel has been released, so we introduce the linux-yocto variant. This version supercedes the 4.4 and 4.8 versions in the tree, leaving us with 4.1 (LTSI), 4.9 (LTS) and 4.10 (most recent) as the three active versions. Build tested against all qemu variants, core-image-kernel-dev + sato, with musl and glibc as the C libraries. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-tiny_4.10.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.10.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.10.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.10.bb
new file mode 100644
index 0000000000..4d4639a97f
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.10.bb
@@ -0,0 +1,25 @@
+KBRANCH ?= "standard/tiny/common-pc"
+LINUX_KERNEL_TYPE = "tiny"
+KCONFIG_MODE = "--allnoconfig"
+
+require recipes-kernel/linux/linux-yocto.inc
+
+LINUX_VERSION ?= "4.10"
+
+KMETA = "kernel-meta"
+KCONF_BSP_AUDIT_LEVEL = "2"
+
+SRCREV_machine ?= "b259a5d744e8955a03405c6b59c5a61724755ea8"
+SRCREV_meta ?= "805ea440c791acee4617820ab32e93f1ccbd9ae2"
+
+PV = "${LINUX_VERSION}+git${SRCPV}"
+
+SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.10.git;branch=${KBRANCH};name=machine \
+ git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.10;destsuffix=${KMETA}"
+
+COMPATIBLE_MACHINE = "(qemux86$)"
+
+# Functionality flags
+KERNEL_FEATURES = ""
+
+KERNEL_DEVICETREE_qemuarm = "versatile-pb.dtb"