aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-tiny_3.4.bb
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2012-10-05 22:30:48 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-10-08 09:19:13 +0100
commitcf25f211ec420e1e8dd48c8e62f60deefe2c6d53 (patch)
treee19a37c7b83faae0ea0b566c500b4748fbecfa80 /meta/recipes-kernel/linux/linux-yocto-tiny_3.4.bb
parent1438228d3b54dfdcf8c36154c927c80fcecf688e (diff)
downloadopenembedded-core-contrib-cf25f211ec420e1e8dd48c8e62f60deefe2c6d53.tar.gz
linux-yocto-tiny: Add tiny recipe for the 3.4 linux-yocto kernel
This recipe builds the "tiny" kernel type defined by the linux-yocto meta-data. Support is defined for the qemux86 machine via common-pc-tiny.scc in the linux-yocto meta branch. The resulting kernel is 1.8 MB and boots to a serial console with with qemux86 and core-image-minimal using the following command: qemu -kernel tmp/deploy/images/bzImage-qemux86.bin -initrd tmp/deploy/images/core-image-minimal-qemux86.cpio.gz -append "root=/dev/ram0 console=ttyS0" -nographic Signed-off-by: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-tiny_3.4.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_3.4.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_3.4.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_3.4.bb
new file mode 100644
index 0000000000..a0c8ffb596
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_3.4.bb
@@ -0,0 +1,27 @@
+require recipes-kernel/linux/linux-yocto.inc
+
+# We need lzma (as CONFIG_KERNEL_LZMA=y)
+DEPENDS += "xz-native"
+
+KBRANCH_DEFAULT = "standard/tiny/base"
+KBRANCH = "${KBRANCH_DEFAULT}"
+LINUX_KERNEL_TYPE = "tiny"
+KCONFIG_MODE = "--allnoconfig"
+
+LINUX_VERSION ?= "3.4.11"
+
+KMETA = "meta"
+
+SRCREV_machine ?= "3fa06aa29078fdb2af431de2d3fdae7d281ba85f"
+SRCREV_meta ?= "a201268353c030d9fafe00f2041976f7437d9386"
+
+
+PR = "${INC_PR}.0"
+PV = "${LINUX_VERSION}+git${SRCPV}"
+
+SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.4;protocol=git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
+
+COMPATIBLE_MACHINE = "(qemux86)"
+
+# Functionality flags
+KERNEL_FEATURES = ""