aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-03-31 13:56:29 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-31 22:57:34 +0100
commit92776093766d4b0bb2613214274fa28dc59b6126 (patch)
tree424aa0da26a01b78b0d43056097153d33a5f608e /meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb
parent6a83546e374b674a58a6d161d655c7e31a3b6da4 (diff)
downloadopenembedded-core-contrib-92776093766d4b0bb2613214274fa28dc59b6126.tar.gz
linux-yocto/3.14: introduce versioned recipes
The release kernel for Yocto 1.6 is the 3.14 kernel, so we introduce the versioned recipes here. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb
new file mode 100644
index 0000000000..2e142bfd90
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb
@@ -0,0 +1,21 @@
+require recipes-kernel/linux/linux-yocto.inc
+
+KBRANCH = "standard/tiny/base"
+LINUX_KERNEL_TYPE = "tiny"
+KCONFIG_MODE = "--allnoconfig"
+
+LINUX_VERSION ?= "3.14"
+
+KMETA = "meta"
+
+SRCREV_machine ?= "0143c6ebb4a2d63b241df5f608b19f483f7eb9e0"
+SRCREV_meta ?= "fc8c30398dbc3cdea787a1042242d4aab689d0ae"
+
+PV = "${LINUX_VERSION}+git${SRCPV}"
+
+SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.14.git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
+
+COMPATIBLE_MACHINE = "(qemux86)"
+
+# Functionality flags
+KERNEL_FEATURES = ""