aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-rt_3.14.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-04-12 00:10:11 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-04-23 11:41:03 +0100
commit8e38a24a9d9cd44733a25d3de307907a788d643d (patch)
tree323e435cb767a40d8850608e8d0fe5905b8a536f /meta/recipes-kernel/linux/linux-yocto-rt_3.14.bb
parenta84c36e0e5e8332ddc5a6c34e1f598d5cb87cee2 (diff)
downloadopenembedded-core-contrib-8e38a24a9d9cd44733a25d3de307907a788d643d.tar.gz
linux-yocto/3.14: aufs, edgerouter config and -rt
Updating the 3.14 SRCREVs to import the following changes: - enable AUFS: a missing Kbuild patch was preventing aufs from compiling - edgerouter: remove RTC configuration options - preempt-rt recipe. The patch for 3.14 is availble, so we populate the recipe. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-rt_3.14.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_3.14.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_3.14.bb b/meta/recipes-kernel/linux/linux-yocto-rt_3.14.bb
new file mode 100644
index 0000000000..330eda4f1f
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_3.14.bb
@@ -0,0 +1,27 @@
+require recipes-kernel/linux/linux-yocto.inc
+
+KBRANCH = "standard/preempt-rt/base"
+KBRANCH_qemuppc = "standard/preempt-rt/qemuppc"
+
+SRCREV_machine ?= "b5ed38affb23ff64a0382ee0dd116ffe74c4a379"
+SRCREV_machine_qemuppc ?= "79cb133d2d1b0b816cc1cd888f4ed4ef81570793"
+SRCREV_meta ?= "09424cee646626c04105f08455a58fabb27eff31"
+
+SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.14.git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
+
+LINUX_VERSION ?= "3.14"
+
+PV = "${LINUX_VERSION}+git${SRCPV}"
+
+KMETA = "meta"
+
+LINUX_KERNEL_TYPE = "preempt-rt"
+
+COMPATIBLE_MACHINE = "(qemux86|qemux86-64|qemuarm|qemuppc|qemumips)"
+
+# Functionality flags
+KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/taskstats/taskstats.scc"
+KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}"
+KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
+KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
+KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc"