summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-dev.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2016-09-26 14:36:02 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-28 10:15:54 +0100
commit6b67018c2c0229a91fbc55c6aafb86781caf2499 (patch)
treeff67cdb0062dcf1786f37d4da504b854df9caf1e /meta/recipes-kernel/linux/linux-yocto-dev.bb
parent8ab1f6073f86d05493bb32a8135c9d912d72f5f0 (diff)
downloadopenembedded-core-contrib-6b67018c2c0229a91fbc55c6aafb86781caf2499.tar.gz
linux-yocto: Move PREFERRED_PROVIDER check to be generic
This check ensures that when the PREFERRED_PROVIDER for virtual/kernel changes, the previous instances gets removed correctly so when the new instance installs files into the shared area there is not an overlap of old and new. [YOCTO #10278] Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-dev.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-dev.bb9
1 files changed, 0 insertions, 9 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-dev.bb b/meta/recipes-kernel/linux/linux-yocto-dev.bb
index dbe58477f5..9154bb7c31 100644
--- a/meta/recipes-kernel/linux/linux-yocto-dev.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-dev.bb
@@ -14,15 +14,6 @@ require recipes-kernel/linux/linux-yocto.inc
# provide this .inc to set specific revisions
include recipes-kernel/linux/linux-yocto-dev-revisions.inc
-# Skip processing of this recipe if it is not explicitly specified as the
-# PREFERRED_PROVIDER for virtual/kernel. This avoids network access required
-# by the use of AUTOREV SRCREVs, which are the default for this recipe.
-python () {
- if d.getVar("PREFERRED_PROVIDER_virtual/kernel", True) != "linux-yocto-dev":
- d.delVar("BB_DONT_CACHE")
- raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-dev to enable it")
-}
-
KBRANCH = "standard/base"
KMETA = "kernel-meta"