summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/kernel-devsrc.bb
diff options
context:
space:
mode:
authorPeter Bergin <peter@berginkonsult.se>2019-11-28 07:14:24 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-12-28 23:25:34 +0000
commit53cccd5b5145c23cac3e227ef71edaf4609c11b5 (patch)
tree3b8f1d5c07309c34dc0cf190ff61cebb7859edc4 /meta/recipes-kernel/linux/kernel-devsrc.bb
parent460222c54e4c65352c0687f2b6c70527cc9a2b4b (diff)
downloadopenembedded-core-contrib-53cccd5b5145c23cac3e227ef71edaf4609c11b5.tar.gz
kernel-devsrc: fix error with old (<4.2) x86 kernels
When using kernel-devsrc for older kernels do_install fails with: | cp: failed to get attributes of 'arch/x86/entry': No such file or directory In the Linux kernel commit 1f57d5d85 "x86/asm/entry: Move the arch/x86/syscalls/ definitions to arch/x86/entry/syscalls/" moved some files copied in the kernel-devsrc recipe. Commit 1f57d5d85 was added in v4.2. To be able to use kernel-devsrc for kernels older than v4.2 this commit make use of find for the files that shall be copied. Signed-off-by: Peter Bergin <peter@berginkonsult.se> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-kernel/linux/kernel-devsrc.bb')
-rw-r--r--meta/recipes-kernel/linux/kernel-devsrc.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta/recipes-kernel/linux/kernel-devsrc.bb b/meta/recipes-kernel/linux/kernel-devsrc.bb
index b68d945a8f..b6f2dbc2b0 100644
--- a/meta/recipes-kernel/linux/kernel-devsrc.bb
+++ b/meta/recipes-kernel/linux/kernel-devsrc.bb
@@ -185,14 +185,14 @@ do_install() {
cp -a --parents tools/include/tools/be_byteshift.h $kerneldir/build/
# required for generate missing syscalls prepare phase
- cp -a --parents arch/x86/entry/syscalls/syscall_32.tbl $kerneldir/build
+ cp -a --parents $(find arch/x86 -type f -name "syscall_32.tbl") $kerneldir/build
if [ "${ARCH}" = "x86" ]; then
# files for 'make prepare' to succeed with kernel-devel
- cp -a --parents arch/x86/entry/syscalls/syscall_32.tbl $kerneldir/build/
- cp -a --parents arch/x86/entry/syscalls/syscalltbl.sh $kerneldir/build/
- cp -a --parents arch/x86/entry/syscalls/syscallhdr.sh $kerneldir/build/
- cp -a --parents arch/x86/entry/syscalls/syscall_64.tbl $kerneldir/build/
+ cp -a --parents $(find arch/x86 -type f -name "syscall_32.tbl") $kerneldir/build/
+ cp -a --parents $(find arch/x86 -type f -name "syscalltbl.sh") $kerneldir/build/
+ cp -a --parents $(find arch/x86 -type f -name "syscallhdr.sh") $kerneldir/build/
+ cp -a --parents $(find arch/x86 -type f -name "syscall_64.tbl") $kerneldir/build/
cp -a --parents arch/x86/tools/relocs_32.c $kerneldir/build/
cp -a --parents arch/x86/tools/relocs_64.c $kerneldir/build/
cp -a --parents arch/x86/tools/relocs.c $kerneldir/build/