summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/kernel-devsrc.bb
diff options
context:
space:
mode:
authorRuslan Bilovol <rbilovol@cisco.com>2020-02-14 21:24:56 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-03-03 13:06:23 +0000
commit3329dd6ea914c5fadbf63ecbfde9c66472df19ee (patch)
tree219216dba98304533e2ed60345f799385c577081 /meta/recipes-kernel/linux/kernel-devsrc.bb
parent6f31da5632220a09ac65b8f361cdc9c64e64ce35 (diff)
downloadopenembedded-core-contrib-3329dd6ea914c5fadbf63ecbfde9c66472df19ee.tar.gz
kernel-devsrc: support 4.4+ ARM/ARM64 kernels
Linux Kernel 4.4 is an LTS kernel so people may still build it with OE. Thus make copying of some files optional: - arm64 module.lds file first appeared with kernel v4.6 commit fd045f6cd98e arm64: add support for module PLTs" - arm32 *.tbl files first appeared in kernel v4.10 in commit 96a8fae0fe09 "ARM: convert to generated system call tables" Signed-off-by: Ruslan Bilovol <rbilovol@cisco.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/kernel-devsrc.bb')
-rw-r--r--meta/recipes-kernel/linux/kernel-devsrc.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-kernel/linux/kernel-devsrc.bb b/meta/recipes-kernel/linux/kernel-devsrc.bb
index 2888236628..5940cc90ea 100644
--- a/meta/recipes-kernel/linux/kernel-devsrc.bb
+++ b/meta/recipes-kernel/linux/kernel-devsrc.bb
@@ -147,7 +147,7 @@ do_install() {
cp -a --parents arch/arm64/kernel/vdso/note.S $kerneldir/build/
cp -a --parents arch/arm64/kernel/vdso/gen_vdso_offsets.sh $kerneldir/build/
- cp -a --parents arch/arm64/kernel/module.lds $kerneldir/build/
+ cp -a --parents arch/arm64/kernel/module.lds $kerneldir/build/ 2>/dev/null || :
fi
if [ "${ARCH}" = "powerpc" ]; then
@@ -187,7 +187,7 @@ do_install() {
# required for generate missing syscalls prepare phase
cp -a --parents $(find arch/x86 -type f -name "syscall_32.tbl") $kerneldir/build
- cp -a --parents $(find arch/arm -type f -name "*.tbl") $kerneldir/build
+ cp -a --parents $(find arch/arm -type f -name "*.tbl") $kerneldir/build 2>/dev/null || :
if [ "${ARCH}" = "x86" ]; then
# files for 'make prepare' to succeed with kernel-devel