summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/kernel-devsrc.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2019-03-07 00:00:19 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-03-07 12:27:28 +0000
commit124c6bf5a0a5cc20d2ebbf04dc7b577cb4f5153a (patch)
tree02c3519ac00a222ad7ff7985d5e0e8893198c17a /meta/recipes-kernel/linux/kernel-devsrc.bb
parent317f95ad38d2d24f4ee40eb737e4f0d6ace6e3f0 (diff)
downloadopenembedded-core-contrib-124c6bf5a0a5cc20d2ebbf04dc7b577cb4f5153a.tar.gz
kernel-devsrc: add files required for on-target build with 5.x
Both powerpc and mips require a few new files for the scripts and prepare targets to work with a 5.0 kernel. We add the required files to the architecture specific blocks, with appropriate backwards compatibility considerations. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/kernel-devsrc.bb')
-rw-r--r--meta/recipes-kernel/linux/kernel-devsrc.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/kernel-devsrc.bb b/meta/recipes-kernel/linux/kernel-devsrc.bb
index 8fc0ffdbb3..cf2b476051 100644
--- a/meta/recipes-kernel/linux/kernel-devsrc.bb
+++ b/meta/recipes-kernel/linux/kernel-devsrc.bb
@@ -150,6 +150,13 @@ do_install() {
cp -a --parents arch/arm64/kernel/module.lds $kerneldir/build/
fi
+ if [ "${ARCH}" = "powerpc" ]; then
+ # 5.0 needs these files, but don't error if they aren't present in the source
+ cp -a --parents arch/${ARCH}/kernel/syscalls/syscall.tbl $kerneldir/build/ 2>/dev/null || :
+ cp -a --parents arch/${ARCH}/kernel/syscalls/syscalltbl.sh $kerneldir/build/ 2>/dev/null || :
+ cp -a --parents arch/${ARCH}/kernel/syscalls/syscallhdr.sh $kerneldir/build/ 2>/dev/null || :
+ fi
+
# include the machine specific headers for ARM variants, if available.
if [ "${ARCH}" = "arm" ]; then
cp -a --parents arch/${ARCH}/mach-*/include $kerneldir/build/
@@ -214,6 +221,9 @@ do_install() {
cp -a --parents kernel/time/timeconst.bc $kerneldir/build
cp -a --parents kernel/bounds.c $kerneldir/build
cp -a --parents Kbuild $kerneldir/build
+ cp -a --parents arch/mips/kernel/syscalls/*.sh $kerneldir/build
+ cp -a --parents arch/mips/kernel/syscalls/*.tbl $kerneldir/build
+ cp -a --parents arch/mips/tools/elf-entry.c $kerneldir/build 2>/dev/null || :
fi
# required to build scripts/selinux/genheaders/genheaders