aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux-libc-headers
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2011-02-14 14:07:38 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-02-15 19:23:59 +0000
commite0f49d2ae40ee7c5e6a804264845b89595e1b06c (patch)
tree9010e6add529c74c4100a4352b21cdaf77938f16 /meta/recipes-kernel/linux-libc-headers
parenta824232c445162c6a6870c4c869b8ec60d8eb445 (diff)
downloadopenembedded-core-contrib-e0f49d2ae40ee7c5e6a804264845b89595e1b06c.tar.gz
linux-libc-headers-yocto: disable device tree generation
Fixes [BUGID #719] The common routines for handling a git based yocto kernel are included from the lib headers recipe to checkout the appropriate branch of the kernel for header generation. linux-yocto.inc includes device tree installation rules which typically apply to a kernel user of the include file, but do not apply to a simple header generation. The fix is to override the DTB variables in this recipe, which disable the device tree installation rules. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta/recipes-kernel/linux-libc-headers')
-rw-r--r--meta/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb b/meta/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb
index 0d5835401e..736d60f7de 100644
--- a/meta/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb
+++ b/meta/recipes-kernel/linux-libc-headers/linux-libc-headers-yocto_git.bb
@@ -12,6 +12,10 @@ PR = "r2"
SRCREV_FORMAT = "meta_machine"
SRC_URI = "git://git.pokylinux.org/linux-yocto-2.6.37;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta"
+# force this to empty to prevent installation failures, we aren't
+# building a device tree as part of kern headers
+KERNEL_DEVICETREE=
+
set_arch() {
case ${TARGET_ARCH} in
arm*) ARCH=arm ;;