aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/latencytop/latencytop_0.5.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-09-07 07:45:00 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-09-12 22:47:16 +0100
commit91b8c2900570720d56a123a90e927f49a6a6095f (patch)
tree13e6a7846f0db0bc90bf97c12be731c0804497fc /meta/recipes-kernel/latencytop/latencytop_0.5.bb
parentf8d3122e9d194aa7fdf5c4c645edfcc7fdcb9ccc (diff)
downloadopenembedded-core-contrib-91b8c2900570720d56a123a90e927f49a6a6095f.tar.gz
latencytop: Fix build with clang
Clang is stricter with syntax checking and flags the functions return values if they dont match with function signatures, Fixed thusly Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-kernel/latencytop/latencytop_0.5.bb')
-rw-r--r--meta/recipes-kernel/latencytop/latencytop_0.5.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta/recipes-kernel/latencytop/latencytop_0.5.bb b/meta/recipes-kernel/latencytop/latencytop_0.5.bb
index cb0a3c5ed1..f31f1bb7ab 100644
--- a/meta/recipes-kernel/latencytop/latencytop_0.5.bb
+++ b/meta/recipes-kernel/latencytop/latencytop_0.5.bb
@@ -10,7 +10,9 @@ PR = "r3"
SRC_URI = "http://pkgs.fedoraproject.org/repo/pkgs/${BPN}/${BP}.tar.gz/73bb3371c6ee0b0e68e25289027e865c/${BP}.tar.gz \
file://latencytop-makefile.patch \
- file://latencytop-fsync.patch"
+ file://latencytop-fsync.patch \
+ file://0001-Rectify-the-function-signatures-to-fix-prototype-mis.patch \
+"
SRC_URI[md5sum] = "73bb3371c6ee0b0e68e25289027e865c"
SRC_URI[sha256sum] = "9e7f72fbea7bd918e71212a1eabaad8488d2c602205d2e3c95d62cd57e9203ef"
@@ -21,7 +23,7 @@ PACKAGECONFIG[x11] = ",,gtk+"
EXTRA_OEMAKE_X = "${@bb.utils.contains('PACKAGECONFIG', 'x11', 'HAS_GTK_GUI=1', '', d)}"
-CFLAGS += "${LDFLAGS}"
+#CFLAGS += "${LDFLAGS}"
do_install() {
oe_runmake install DESTDIR=${D} ${EXTRA_OEMAKE_X}