summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/kmod
diff options
context:
space:
mode:
authorJoshua Lock <joshua.lock@collabora.co.uk>2015-09-14 16:41:20 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-09-16 21:38:19 +0100
commitdc184ace9d72a2d4f8eeec831942663cd3b1fd47 (patch)
treec3b29b6f7ecad17a33de99207276a9f91b736589 /meta/recipes-kernel/kmod
parent518fce265e6f2b82f986fbda803e27b77f499c5a (diff)
downloadopenembedded-core-contrib-dc184ace9d72a2d4f8eeec831942663cd3b1fd47.tar.gz
kmod: fix link creation when base_bindir != /bin
If base_bindir is not a direct child of / the link creation in do_install_append creates incorrect relative links. Instead pass a full path to the link source too the lnr script to create a relative link. Signed-off-by: Joshua Lock <joshua.lock@collabora.co.uk> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-kernel/kmod')
-rw-r--r--meta/recipes-kernel/kmod/kmod_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-kernel/kmod/kmod_git.bb b/meta/recipes-kernel/kmod/kmod_git.bb
index ba4d85eda4..e0bb95c8f6 100644
--- a/meta/recipes-kernel/kmod/kmod_git.bb
+++ b/meta/recipes-kernel/kmod/kmod_git.bb
@@ -21,9 +21,9 @@ do_install_append () {
install -dm755 ${D}${base_bindir}
install -dm755 ${D}${base_sbindir}
# add symlinks to kmod
- ln -s ..${base_bindir}/kmod ${D}${base_bindir}/lsmod
+ lnr ${D}${base_bindir}/kmod ${D}${base_bindir}/lsmod
for tool in insmod rmmod depmod modinfo modprobe; do
- ln -s ..${base_bindir}/kmod ${D}${base_sbindir}/${tool}
+ lnr ${D}${base_bindir}/kmod ${D}${base_sbindir}/${tool}
done
# configuration directories
install -dm755 ${D}${base_libdir}/depmod.d
/a> 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384