aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/kmod/kmod/0001-Makefile.am-fix-parallel-build-problem.patch
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2015-04-08 11:25:34 +0800
committerChen Qi <Qi.Chen@windriver.com>2015-04-08 18:21:35 +0800
commitf59ab3d057c5535b83735ed997f9bcc39fa0b661 (patch)
treecda7ef044f2f3178d6d0bdcfd99b4a9c7d60e781 /meta/recipes-kernel/kmod/kmod/0001-Makefile.am-fix-parallel-build-problem.patch
parenta8b6e39f2cfc6761a1c26a4516acc99120e025ea (diff)
downloadopenembedded-core-contrib-f59ab3d057c5535b83735ed997f9bcc39fa0b661.tar.gz
kmod: upgrade to 20
The following patches are rebased. -- Change-to-calling-bswap_-instead-of-htobe-and-be-toh.patch -- avoid_parallel_tests.patch The following patch is added to solve a parallel build bug. -- 0001-Makefile.am-fix-parallel-build-problem.patch Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Diffstat (limited to 'meta/recipes-kernel/kmod/kmod/0001-Makefile.am-fix-parallel-build-problem.patch')
-rw-r--r--meta/recipes-kernel/kmod/kmod/0001-Makefile.am-fix-parallel-build-problem.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-kernel/kmod/kmod/0001-Makefile.am-fix-parallel-build-problem.patch b/meta/recipes-kernel/kmod/kmod/0001-Makefile.am-fix-parallel-build-problem.patch
new file mode 100644
index 0000000000..49b0209029
--- /dev/null
+++ b/meta/recipes-kernel/kmod/kmod/0001-Makefile.am-fix-parallel-build-problem.patch
@@ -0,0 +1,29 @@
+Upstream-Status: Pending
+
+Subject: Makefile.am: fix parallel build problem
+
+Fix parallel build problem to avoid errors like below.
+
+ install: cannot stat 'testsuite/module-playground/mod-fake-cciss.ko': No such file or directory
+
+Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
+---
+ Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 9457655..d5b02eb 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -237,7 +237,7 @@ rootfs: build-module-playground
+
+ .PHONY: rootfs build-playground
+
+-$(ROOTFS): $(ROOTFS_PRISTINE)
++$(ROOTFS): $(ROOTFS_PRISTINE) build-module-playground
+ $(CREATE_ROOTFS)
+
+ TESTSUITE_OVERRIDE_LIBS = \
+--
+1.9.1
+