aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/dtc/dtc
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-01-02 01:22:42 -0800
committerSaul Wold <sgw@linux.intel.com>2011-01-02 01:25:41 -0800
commitabebecacbd531fb2595db84bf14ee9e85cc1b3eb (patch)
tree061f344dfcc910fe202be6405bd63a92d937f5ba /meta/recipes-kernel/dtc/dtc
parent33d91c07378dab39b5c6f2693e24856c06245b2f (diff)
downloadopenembedded-core-contrib-abebecacbd531fb2595db84bf14ee9e85cc1b3eb.tar.gz
dtc: add patch to remove -Os for PPC
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-kernel/dtc/dtc')
-rw-r--r--meta/recipes-kernel/dtc/dtc/remove_space_opt.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta/recipes-kernel/dtc/dtc/remove_space_opt.patch b/meta/recipes-kernel/dtc/dtc/remove_space_opt.patch
new file mode 100644
index 0000000000..805bf58796
--- /dev/null
+++ b/meta/recipes-kernel/dtc/dtc/remove_space_opt.patch
@@ -0,0 +1,16 @@
+Remove the -Os flag
+
+Signed-off-by: Saul Wold <sgw@linux.intel.com>
+Index: git/Makefile
+===================================================================
+--- git.orig/Makefile
++++ git/Makefile
+@@ -18,7 +18,7 @@ CONFIG_LOCALVERSION =
+ CPPFLAGS = -I libfdt
+ WARNINGS = -Werror -Wall -Wpointer-arith -Wcast-qual -Wnested-externs \
+ -Wstrict-prototypes -Wmissing-prototypes
+-CFLAGS = -g -Os -fPIC -Werror $(WARNINGS)
++CFLAGS = -g -fPIC -Werror $(WARNINGS)
+
+ BISON = bison
+ LEX = flex