aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-03-09 20:56:06 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-11 06:25:23 -0700
commit0cff8ae54066b25ffbe1efaa3f0a1d84aa89ebe1 (patch)
tree9fd92db4dd70641cbb2f50e6c7f17581509511c4 /meta/recipes-graphics
parent625be3dd6e3069333a3c94ca8f23129b23e4425b (diff)
downloadopenembedded-core-contrib-0cff8ae54066b25ffbe1efaa3f0a1d84aa89ebe1.tar.gz
mesa: refresh patches
The patch tool will apply patches by default with "fuzz", which is where if the hunk context isn't present but what is there is close enough, it will force the patch in. Whilst this is useful when there's just whitespace changes, when applied to source it is possible for a patch applied with fuzz to produce broken code which still compiles (see #10450). This is obviously bad. We'd like to eventually have do_patch() rejecting any fuzz on these grounds. For that to be realistic the existing patches with fuzz need to be rebased and reviewed. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/mesa/files/0001-Makefile.vulkan.am-explictly-add-lib-expat-to-intel-.patch13
-rw-r--r--meta/recipes-graphics/mesa/files/0001-Use-wayland-scanner-in-the-path.patch19
2 files changed, 13 insertions, 19 deletions
diff --git a/meta/recipes-graphics/mesa/files/0001-Makefile.vulkan.am-explictly-add-lib-expat-to-intel-.patch b/meta/recipes-graphics/mesa/files/0001-Makefile.vulkan.am-explictly-add-lib-expat-to-intel-.patch
index ff8eda458c..f908d46550 100644
--- a/meta/recipes-graphics/mesa/files/0001-Makefile.vulkan.am-explictly-add-lib-expat-to-intel-.patch
+++ b/meta/recipes-graphics/mesa/files/0001-Makefile.vulkan.am-explictly-add-lib-expat-to-intel-.patch
@@ -28,10 +28,10 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
src/intel/Makefile.vulkan.am | 1 +
1 file changed, 1 insertion(+)
-diff --git a/src/intel/Makefile.vulkan.am b/src/intel/Makefile.vulkan.am
-index 271b0a5..8fbe2c8 100644
---- a/src/intel/Makefile.vulkan.am
-+++ b/src/intel/Makefile.vulkan.am
+Index: mesa-17.3.6/src/intel/Makefile.vulkan.am
+===================================================================
+--- mesa-17.3.6.orig/src/intel/Makefile.vulkan.am
++++ mesa-17.3.6/src/intel/Makefile.vulkan.am
@@ -144,6 +144,7 @@ VULKAN_LIB_DEPS = \
$(LIBDRM_LIBS) \
$(PTHREAD_LIBS) \
@@ -39,7 +39,4 @@ index 271b0a5..8fbe2c8 100644
+ $(EXPAT_LIBS) \
-lm
- if HAVE_PLATFORM_X11
---
-2.7.4
-
+ if HAVE_PLATFORM_ANDROID
diff --git a/meta/recipes-graphics/mesa/files/0001-Use-wayland-scanner-in-the-path.patch b/meta/recipes-graphics/mesa/files/0001-Use-wayland-scanner-in-the-path.patch
index eb6ff4ff04..2444b2846b 100644
--- a/meta/recipes-graphics/mesa/files/0001-Use-wayland-scanner-in-the-path.patch
+++ b/meta/recipes-graphics/mesa/files/0001-Use-wayland-scanner-in-the-path.patch
@@ -14,12 +14,12 @@ Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
configure.ac | 7 +------
1 file changed, 1 insertion(+), 6 deletions(-)
-diff --git a/configure.ac b/configure.ac
-index 2c7e636fac..d2b2350739 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -2174,12 +2174,7 @@ if test "x$with_platforms" != xauto; then
- with_egl_platforms=$with_platforms
+Index: mesa-17.3.6/configure.ac
+===================================================================
+--- mesa-17.3.6.orig/configure.ac
++++ mesa-17.3.6/configure.ac
+@@ -1694,12 +1694,7 @@ if test "x$with_platforms" = xauto; then
+ with_platforms=$with_egl_platforms
fi
-PKG_CHECK_MODULES([WAYLAND_SCANNER], [wayland-scanner],
@@ -30,8 +30,5 @@ index 2c7e636fac..d2b2350739 100644
-fi
+AC_PATH_PROG([WAYLAND_SCANNER], [wayland-scanner])
- # Do per-EGL platform setups and checks
- egl_platforms=`IFS=', '; echo $with_egl_platforms`
---
-2.13.0
-
+ PKG_CHECK_EXISTS([wayland-protocols >= $WAYLAND_PROTOCOLS_REQUIRED], [have_wayland_protocols=yes], [have_wayland_protocols=no])
+ if test "x$have_wayland_protocols" = xyes; then