aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-02-12 17:39:34 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-02-15 21:58:27 +0000
commit60ae5c2eb0a06a84aa48e9ec1eaa0a619dc56629 (patch)
treec37939584ab83a54c78dd298bff144603a51dff9 /meta/recipes-graphics
parenteee50b24eeff92e247942076ab6890c6b19a0f0f (diff)
downloadopenembedded-core-contrib-60ae5c2eb0a06a84aa48e9ec1eaa0a619dc56629.tar.gz
meta: enable parallel build for several recipes
I used a for loop to build these packages more than 520 times, these recipes never failed. (From OE-Core rev: 7957c5bc2771a763d26e50e716733c6335cef3c2) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/libsdl/libsdl_1.2.15.bb2
-rw-r--r--meta/recipes-graphics/libsdl2/libsdl2_2.0.3.bb2
-rw-r--r--meta/recipes-graphics/xorg-lib/libpthread-stubs_0.3.bb1
-rw-r--r--meta/recipes-graphics/xorg-lib/xcb-util.inc2
4 files changed, 0 insertions, 7 deletions
diff --git a/meta/recipes-graphics/libsdl/libsdl_1.2.15.bb b/meta/recipes-graphics/libsdl/libsdl_1.2.15.bb
index e544b60eae..266bd42467 100644
--- a/meta/recipes-graphics/libsdl/libsdl_1.2.15.bb
+++ b/meta/recipes-graphics/libsdl/libsdl_1.2.15.bb
@@ -53,8 +53,6 @@ EXTRA_OECONF = "--disable-static --enable-cdrom --enable-threads --enable-timers
PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'alsa', 'alsa', '', d)}"
PACKAGECONFIG[alsa] = "--enable-alsa --disable-alsatest,--disable-alsa,alsa-lib,"
-PARALLEL_MAKE = ""
-
EXTRA_AUTORECONF += "--include=acinclude --exclude=autoheader"
do_configure_prepend() {
diff --git a/meta/recipes-graphics/libsdl2/libsdl2_2.0.3.bb b/meta/recipes-graphics/libsdl2/libsdl2_2.0.3.bb
index 38304a96a4..197f962824 100644
--- a/meta/recipes-graphics/libsdl2/libsdl2_2.0.3.bb
+++ b/meta/recipes-graphics/libsdl2/libsdl2_2.0.3.bb
@@ -42,8 +42,6 @@ EXTRA_OECONF = "--disable-oss --disable-esd --disable-arts \
PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'alsa', 'alsa', '', d)}"
PACKAGECONFIG[alsa] = "--enable-alsa --disable-alsatest,--disable-alsa,alsa-lib,"
-PARALLEL_MAKE = ""
-
EXTRA_AUTORECONF += "--include=acinclude --exclude=autoheader"
do_configure_prepend() {
diff --git a/meta/recipes-graphics/xorg-lib/libpthread-stubs_0.3.bb b/meta/recipes-graphics/xorg-lib/libpthread-stubs_0.3.bb
index 3e7ef27bed..5514c7f5e8 100644
--- a/meta/recipes-graphics/xorg-lib/libpthread-stubs_0.3.bb
+++ b/meta/recipes-graphics/xorg-lib/libpthread-stubs_0.3.bb
@@ -7,7 +7,6 @@ SECTION = "x11/libs"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://COPYING;md5=6edc1fea03d959f0c2d743fe5ca746ad"
-PARALLEL_MAKE = ""
#DEPENDS = "xcb-proto xproto libxau libxslt-native"
# DEPENDS += "xsltproc-native gperf-native"
diff --git a/meta/recipes-graphics/xorg-lib/xcb-util.inc b/meta/recipes-graphics/xorg-lib/xcb-util.inc
index 7dad545c33..d15cf9fba1 100644
--- a/meta/recipes-graphics/xorg-lib/xcb-util.inc
+++ b/meta/recipes-graphics/xorg-lib/xcb-util.inc
@@ -16,8 +16,6 @@ SECTION = "x11/libs"
DEPENDS = "libxcb"
DEPENDS += "gperf-native"
-PARALLEL_MAKE = ""
-
SRC_URI = "http://xcb.freedesktop.org/dist/${BPN}-${PV}.tar.bz2"
inherit autotools pkgconfig