aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2015-07-02 15:03:11 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-16 15:08:42 +0100
commit9c746017af381884cc20c7cd563fc429c2c66112 (patch)
tree46f7d3975611484b0e6eb196fb3b701e70a11f59 /meta/recipes-graphics
parent5f7403151fc8bfd5b1d77f6626717c8b84d33d93 (diff)
downloadopenembedded-core-contrib-9c746017af381884cc20c7cd563fc429c2c66112.tar.gz
mesa: respect MESA_EGL_NO_X11_HEADERS even with x11 in PACKAGECONFIG
* commit a5ebdb6ad8e4f94ac819275d55575230e057e4ae Author: Valentin Popa <valentin.popa@intel.com> Date: Tue Feb 18 13:32:16 2014 +0200 Subject: mesa: upgrade to 9.2.5 introduced this do_install_append, but doesn't explain why it doesn't respect MESA_EGL_NO_X11_HEADERS flag anymore. Not respecting MESA_EGL_NO_X11_HEADERS breaks any build which is using qtdeclarative+egl in distribution which has x11 in mesa PACKAGECONFIG (e.g. my bitbake world builds). The problem is that qtdeclarative is using "None" symbol in QSGTexture::Filtering enum, it's possible to rename it in qtdeclarative, but it's quite invasive and changes qtdeclarative public APIs, see: https://github.com/webOS-ports/meta-webos-ports/commit/31aa85787a7513e279165a25f6f06ea72c576314 so it was rejected by upstream and I don't want to maintain it in meta-qt5 - changing public API in OE build is even worse than if upstream does it. * This change returns MESA_EGL_NO_X11_HEADERS flag so it's relatively easy to resolve this conflict in such setups by preventing Xlib.h inclusion. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/mesa/mesa_10.5.8.bb2
-rw-r--r--meta/recipes-graphics/mesa/mesa_git.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-graphics/mesa/mesa_10.5.8.bb b/meta/recipes-graphics/mesa/mesa_10.5.8.bb
index 7cfef0c6a1..072cde9395 100644
--- a/meta/recipes-graphics/mesa/mesa_10.5.8.bb
+++ b/meta/recipes-graphics/mesa/mesa_10.5.8.bb
@@ -9,6 +9,6 @@ SRC_URI[sha256sum] = "2866b855c5299a4aed066338c77ff6467c389b2c30ada7647be8758663
#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
do_install_append() {
if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
- sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)/#if ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
+ sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
fi
}
diff --git a/meta/recipes-graphics/mesa/mesa_git.bb b/meta/recipes-graphics/mesa/mesa_git.bb
index 8f70f6721b..c0345178c4 100644
--- a/meta/recipes-graphics/mesa/mesa_git.bb
+++ b/meta/recipes-graphics/mesa/mesa_git.bb
@@ -17,6 +17,6 @@ inherit pythonnative
#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
do_install_append() {
if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then
- sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)/#if ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
+ sed -i -e 's/^#if defined(MESA_EGL_NO_X11_HEADERS)$/#if defined(MESA_EGL_NO_X11_HEADERS) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h
fi
}