aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-06-15 16:31:28 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-18 09:12:02 +0100
commit8fe5ca4c6ed49f3f4b0dc67d0932e010bc32051b (patch)
treed8c455b50153171ed9d8584d94b3055f7d8b3cb6 /meta/recipes-graphics
parent3c63274c306c46d2ec9210b1b505b2a0aafccb70 (diff)
downloadopenembedded-core-contrib-8fe5ca4c6ed49f3f4b0dc67d0932e010bc32051b.tar.gz
piglit: Add missing inclusion of Xutil.h
The EGL tests rely on Xutil.h being included. Some EGL implementation does not explitly include it by default and than the build fail. This fixes the build in imx53qsb board, of meta-fsl-arm, but is a generic fix. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/piglit/piglit/0001-tests-Fix-missing-include-of-Xutil.h.patch28
-rw-r--r--meta/recipes-graphics/piglit/piglit_git.bb5
2 files changed, 31 insertions, 2 deletions
diff --git a/meta/recipes-graphics/piglit/piglit/0001-tests-Fix-missing-include-of-Xutil.h.patch b/meta/recipes-graphics/piglit/piglit/0001-tests-Fix-missing-include-of-Xutil.h.patch
new file mode 100644
index 0000000000..c27cc04f01
--- /dev/null
+++ b/meta/recipes-graphics/piglit/piglit/0001-tests-Fix-missing-include-of-Xutil.h.patch
@@ -0,0 +1,28 @@
+Upstream-Status: Backport
+Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
+
+From e40e0a25f996d2e205c4bdec2c8a5cc7f74e5065 Mon Sep 17 00:00:00 2001
+From: Otavio Salvador <otavio@ossystems.com.br>
+Date: Mon, 15 Jun 2015 16:25:30 -0300
+Subject: tests: Fix missing include of Xutil.h
+
+The EGL tests rely on Xutil.h being included. Some EGL implementation
+does not explitly include it by default and then the build fails.
+
+Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
+Reviewed-by: Neil Roberts <neil@linux.intel.com>
+
+diff --git a/tests/egl/egl-configless-context.c b/tests/egl/egl-configless-context.c
+index 0504a26..154b55c 100644
+--- a/tests/egl/egl-configless-context.c
++++ b/tests/egl/egl-configless-context.c
+@@ -32,6 +32,7 @@
+ /* Chunks of code in this file are taken from egl-util.c */
+
+ #include <X11/Xlib.h>
++#include <X11/Xutil.h>
+
+ #include "piglit-util-gl.h"
+ #include "piglit-util-egl.h"
+--
+cgit v0.10.2
diff --git a/meta/recipes-graphics/piglit/piglit_git.bb b/meta/recipes-graphics/piglit/piglit_git.bb
index 75e41fefc2..9e6dc2c406 100644
--- a/meta/recipes-graphics/piglit/piglit_git.bb
+++ b/meta/recipes-graphics/piglit/piglit_git.bb
@@ -2,7 +2,8 @@ SUMMARY = "OpenGL driver testing framework"
LICENSE = "MIT & LGPLv2+ & GPLv3 & GPLv2+ & BSD-3-Clause"
LIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0"
-SRC_URI = "git://anongit.freedesktop.org/piglit"
+SRC_URI = "git://anongit.freedesktop.org/piglit \
+ file://0001-tests-Fix-missing-include-of-Xutil.h.patch"
# From 2014/12/04
SRCREV = "126c7d049b8f32e541625d5a35fbc5f5e4e7fbf8"
@@ -28,4 +29,4 @@ RDEPENDS_${PN} = "waffle python python-mako python-json python-subprocess \
mesa-demos bash \
"
-INSANE_SKIP_${PN} += "dev-so" \ No newline at end of file
+INSANE_SKIP_${PN} += "dev-so"