aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2015-12-16 16:08:13 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-22 16:08:43 +0000
commitad8337a127a8af321396b78a1cf331b54e4e0515 (patch)
tree9653717fb938a72d9b77629026bf9a0d0a25bd08 /meta/recipes-graphics
parent35f4e506cd16a6165318c79030d5e54d06f1fd06 (diff)
downloadopenembedded-core-contrib-ad8337a127a8af321396b78a1cf331b54e4e0515.tar.gz
pixman: check neon support via TUNE_FEATURES, not the _armv7a over-ride
Neon support is optional in armv7a so the _armv7a over-ride is not the best way to determine whether or not the target supports neon. Since pixman will always use neon in preference to 'simd' (ie VFPv2) if it can, it's safe to disable the simd routines if the target is known to support neon. Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/xorg-lib/pixman_0.32.8.bb7
1 files changed, 3 insertions, 4 deletions
diff --git a/meta/recipes-graphics/xorg-lib/pixman_0.32.8.bb b/meta/recipes-graphics/xorg-lib/pixman_0.32.8.bb
index e13b9adffb..16e68fc071 100644
--- a/meta/recipes-graphics/xorg-lib/pixman_0.32.8.bb
+++ b/meta/recipes-graphics/xorg-lib/pixman_0.32.8.bb
@@ -19,13 +19,12 @@ PE = "1"
IWMMXT = "--disable-arm-iwmmxt"
LOONGSON_MMI = "--disable-loongson-mmi"
-NEON = " --disable-arm-neon "
-NEON_class-nativesdk = " --disable-arm-neon "
-NEON_armv7a = " "
-NEON_armv7a-vfp-neon = " "
+# If target supports neon then disable the 'simd' (ie VFPv2) fallback, otherwise disable neon.
+NEON = "${@bb.utils.contains("TUNE_FEATURES", "neon", "--disable-arm-simd", "--disable-arm-neon" ,d)}"
EXTRA_OECONF = "--disable-gtk ${IWMMXT} ${LOONGSON_MMI} ${NEON}"
EXTRA_OECONF_class-native = "--disable-gtk"
+EXTRA_OECONF_class-nativesdk = "--disable-gtk"
SRC_URI += "\
file://0001-ARM-qemu-related-workarounds-in-cpu-features-detecti.patch \