aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2011-03-28 13:14:37 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-03-29 14:09:36 +0100
commit8d26abb57e901f58b5c8782c110c52a437accb51 (patch)
treecaf109ead977eedc2d0ba46603ccfaeece6a75a8 /meta/recipes-graphics
parent9768214eef2d6d8ad37a535877cae1eb0f044c2b (diff)
downloadopenembedded-core-contrib-8d26abb57e901f58b5c8782c110c52a437accb51.tar.gz
clutter-box2d: add version 0.10.0 for use with clutter 1.6
Don't specificy dependant clutter version in inc file, this enables the inc file to be re-used accross Clutter versions. Signed-off-by: Joshua Lock <josh@linux.intel.com>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/clutter/clutter-box2d-1.6_0.10.0.bb20
-rw-r--r--meta/recipes-graphics/clutter/clutter-box2d.inc4
-rw-r--r--meta/recipes-graphics/clutter/clutter-box2d/fix-disable-introspection.patch28
-rw-r--r--meta/recipes-graphics/clutter/clutter-box2d_git.bb2
4 files changed, 51 insertions, 3 deletions
diff --git a/meta/recipes-graphics/clutter/clutter-box2d-1.6_0.10.0.bb b/meta/recipes-graphics/clutter/clutter-box2d-1.6_0.10.0.bb
new file mode 100644
index 0000000000..cad8cfcc86
--- /dev/null
+++ b/meta/recipes-graphics/clutter/clutter-box2d-1.6_0.10.0.bb
@@ -0,0 +1,20 @@
+require clutter-box2d.inc
+
+PR = "r0"
+
+SRC_URI = "http://source.clutter-project.org/sources/clutter-box2d/0.10/clutter-box2d-${PV}.tar.bz2 \
+ file://fix-disable-introspection.patch"
+
+S = "${WORKDIR}/clutter-box2d-${PV}"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
+
+BASE_CONF += "--disable-introspection"
+
+do_configure_prepend () {
+ # Disable DOLT
+ sed -i -e 's/^DOLT//' ${S}/configure.ac
+}
+
+SRC_URI[md5sum] = "51618976ca6a5d536c4eac5f0e120d9d"
+SRC_URI[sha256sum] = "1e42d0cea429e4dc953a1f652672dbd322b3938846e99bab35f463de6fd8ae7f"
diff --git a/meta/recipes-graphics/clutter/clutter-box2d.inc b/meta/recipes-graphics/clutter/clutter-box2d.inc
index 0249984b17..0574db3d51 100644
--- a/meta/recipes-graphics/clutter/clutter-box2d.inc
+++ b/meta/recipes-graphics/clutter/clutter-box2d.inc
@@ -2,8 +2,6 @@ DESCRIPTION = "Clutter Box2D"
HOMEPAGE = "http://www.clutter-project.org/"
LICENSE = "Catto"
-DEPENDS = "clutter-1.4"
-
# The main clutter lib is machine specific so we need to be too
PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -13,3 +11,5 @@ do_install_append () {
install -d ${D}${bindir}
install ${S}/examples/.libs/blockbox ${D}${bindir}
}
+
+FILESPATH = "${FILE_DIRNAME}/clutter-box2d"
diff --git a/meta/recipes-graphics/clutter/clutter-box2d/fix-disable-introspection.patch b/meta/recipes-graphics/clutter/clutter-box2d/fix-disable-introspection.patch
new file mode 100644
index 0000000000..cfb50dc703
--- /dev/null
+++ b/meta/recipes-graphics/clutter/clutter-box2d/fix-disable-introspection.patch
@@ -0,0 +1,28 @@
+Even with introspection disabled clutter-box2d would try to install the gir
+files.
+This patch ignored the while introspection related section of the Makefile if
+introspection is disabled.
+
+JL 28/03/11
+josh@linux.intel.com
+
+Index: clutter-box2d-0.10.0/clutter-box2d/Makefile.am
+===================================================================
+--- clutter-box2d-0.10.0.orig/clutter-box2d/Makefile.am
++++ clutter-box2d-0.10.0/clutter-box2d/Makefile.am
+@@ -41,6 +41,8 @@ EXTRA_DIST = \
+
+ BUILT_GIRSOURCES =
+
++if HAVE_INTROSPECTION
++
+ ClutterBox2D-@CLUTTER_BOX2D_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libclutter-box2d-@CLUTTER_BOX2D_API_VERSION@.la
+ $(QUIET_GEN)$(INTROSPECTION_SCANNER) -v \
+ --namespace ClutterBox2D --nsversion=@CLUTTER_BOX2D_API_VERSION@ \
+@@ -70,3 +72,5 @@ typelibs_DATA = $(BUILT_GIRSOURCES:.gir=
+
+ CLEANFILES=
+ CLEANFILES += $(BUILT_GIRSOURCES) $(typelibs_DATA)
++
++endif
+\ No newline at end of file
diff --git a/meta/recipes-graphics/clutter/clutter-box2d_git.bb b/meta/recipes-graphics/clutter/clutter-box2d_git.bb
index 6b718d5bed..62b5c802d1 100644
--- a/meta/recipes-graphics/clutter/clutter-box2d_git.bb
+++ b/meta/recipes-graphics/clutter/clutter-box2d_git.bb
@@ -9,4 +9,4 @@ SRC_URI = "git://git.clutter-project.org/clutter-box2d.git;protocol=git"
S = "${WORKDIR}/git"
-
+DEPENDS += "clutter-1.4"