aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2017-08-23 10:50:16 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-24 09:33:20 +0100
commit152b59e07aed76de158d553178a2710330bc4cc1 (patch)
treee66305b594930295889a64b2eb0433a65fbb7f95 /meta/recipes-graphics
parentdcb6cd19fb8c639cb844d116fb83827267f37421 (diff)
downloadopenembedded-core-contrib-152b59e07aed76de158d553178a2710330bc4cc1.tar.gz
vulkan: Only build when 'vulkan' distro flag is set
Only build with the vulkan distro flag is set. (References to this flag were found in the mesa recipe.) In addition, only set the RRECOMEMND to mesa, if 'opengl' flag is set. Mesa required opengl distro flag to build. Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/vulkan/vulkan-demos_git.bb2
-rw-r--r--meta/recipes-graphics/vulkan/vulkan_1.0.51.0.bb4
2 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-graphics/vulkan/vulkan-demos_git.bb b/meta/recipes-graphics/vulkan/vulkan-demos_git.bb
index 828ef501a7..0b8943508b 100644
--- a/meta/recipes-graphics/vulkan/vulkan-demos_git.bb
+++ b/meta/recipes-graphics/vulkan/vulkan-demos_git.bb
@@ -15,6 +15,8 @@ SRCREV = "18df00c7b4677b0889486e16977857aa987947e2"
UPSTREAM_CHECK_GITTAGREGEX = "These are not the releases you're looking for"
S = "${WORKDIR}/git"
+REQUIRED_DISTRO_FEATURES = 'vulkan'
+
inherit cmake distro_features_check
DEPENDS = "vulkan assimp"
diff --git a/meta/recipes-graphics/vulkan/vulkan_1.0.51.0.bb b/meta/recipes-graphics/vulkan/vulkan_1.0.51.0.bb
index 555d741273..1893269fcb 100644
--- a/meta/recipes-graphics/vulkan/vulkan_1.0.51.0.bb
+++ b/meta/recipes-graphics/vulkan/vulkan_1.0.51.0.bb
@@ -18,6 +18,7 @@ UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)"
S = "${WORKDIR}/git"
+REQUIRED_DISTRO_FEATURES = "vulkan"
inherit cmake python3native lib_package distro_features_check
ANY_OF_DISTRO_FEATURES = "x11 wayland"
@@ -32,4 +33,5 @@ PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '' ,d)}
PACKAGECONFIG[x11] = "-DBUILD_WSI_XLIB_SUPPORT=ON -DBUILD_WSI_XCB_SUPPORT=ON -DDEMOS_WSI_SELECTION=XCB, -DBUILD_WSI_XLIB_SUPPORT=OFF -DBUILD_WSI_XCB_SUPPORT=OFF -DDEMOS_WSI_SELECTION=WAYLAND, libxcb libx11 libxrandr"
PACKAGECONFIG[wayland] = "-DBUILD_WSI_WAYLAND_SUPPORT=ON, -DBUILD_WSI_WAYLAND_SUPPORT=OFF, wayland"
-RRECOMMENDS_${PN} = "mesa-vulkan-drivers"
+# mesa requires opengl
+RRECOMMENDS_${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'mesa-vulkan-drivers', '', d)}"