aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-11 23:03:28 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-16 14:20:17 +0100
commit8f3be1925b9da20526a722149b03f697247ea1bf (patch)
treeb75c9d9c22522ac87e9bdf605c65de6e1be35fef /meta/recipes-graphics
parentfe10ea6bd6078828016d3954ad9b290f638d6dbb (diff)
downloadopenembedded-core-contrib-8f3be1925b9da20526a722149b03f697247ea1bf.tar.gz
wayland: Fix hardlink corruption issue
The way this code was working, the m4 file is hardlinked to the copies which would be packaged and could lead to the native m4 file being used in the target packages. By removing the file first the hardlink is broken and this avoids corruption (since cp uses open to change the file contents). Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/wayland/wayland_1.6.0.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/wayland_1.6.0.bb b/meta/recipes-graphics/wayland/wayland_1.6.0.bb
index 00713bff3f..6413a0a153 100644
--- a/meta/recipes-graphics/wayland/wayland_1.6.0.bb
+++ b/meta/recipes-graphics/wayland/wayland_1.6.0.bb
@@ -36,5 +36,6 @@ do_install_append_class-native() {
}
sysroot_stage_all_append_class-target () {
+ rm ${SYSROOT_DESTDIR}/${datadir}/aclocal/wayland-scanner.m4
cp ${STAGING_DATADIR_NATIVE}/aclocal/wayland-scanner.m4 ${SYSROOT_DESTDIR}/${datadir}/aclocal/
}