aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2015-06-10 20:19:08 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-11 23:57:51 +0100
commit562c8907d6afcf50695f8964cdebd05fc1085742 (patch)
tree8aa8f63bae13241139caf3cfb0eb51f2ffc69982 /meta/recipes-graphics
parent2cfa8427d77f680df37c12d00125501ebe7c38a3 (diff)
downloadopenembedded-core-contrib-562c8907d6afcf50695f8964cdebd05fc1085742.tar.gz
piglit: upgrade to more recent srvrev
Upgrade to 126c7d from December 2014. Still not the latest but it's got no added build dependencies and importantly handles installs out of the box instead of us having to hack and kludge, and builds with cmake 3.x. The usage has changed: now there's a "piglit" binary that has run/resume/summary subcommands, for example: $ piglit run quick quick-results/ For reference the quick test suite on a IvyBridge NUC results in: [27714/27714] crash: 3, fail: 326, pass: 18275, skip: 9107, warn: 3 - Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/piglit/piglit_git.bb37
1 files changed, 6 insertions, 31 deletions
diff --git a/meta/recipes-graphics/piglit/piglit_git.bb b/meta/recipes-graphics/piglit/piglit_git.bb
index e33e4a7237..75e41fefc2 100644
--- a/meta/recipes-graphics/piglit/piglit_git.bb
+++ b/meta/recipes-graphics/piglit/piglit_git.bb
@@ -4,8 +4,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0"
SRC_URI = "git://anongit.freedesktop.org/piglit"
-# From 2012/12/30.
-SRCREV = "bbeff5d21b06d37338ad28e42d88f499bef13268"
+# From 2014/12/04
+SRCREV = "126c7d049b8f32e541625d5a35fbc5f5e4e7fbf8"
# (when PV goes above 1.0 remove the trailing r)
PV = "1.0+gitr${SRCPV}"
@@ -17,40 +17,15 @@ inherit cmake pythonnative distro_features_check
# depends on virtual/libx11
REQUIRED_DISTRO_FEATURES = "x11"
-# As piglit doesn't install, enforce in-tree builds so that we can easily copy
-# contents out of $S and $B.
-B="${S}"
-
PACKAGECONFIG ??= ""
PACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"
-# CMake sets the rpath at build time with the source tree, and will reset it at
-# install time. As we don't install this doesn't happen, so force the rpath to
-# what we need.
-EXTRA_OECMAKE = "-DCMAKE_BUILD_WITH_INSTALL_RPATH=1 -DCMAKE_INSTALL_RPATH=${libdir}/piglit/lib"
-
-do_install() {
- install -d ${D}${bindir}
- install -m 0755 piglit-*.py ${D}${bindir}
-
- install -d ${D}${libdir}/piglit/
-
- install -d ${D}${libdir}/piglit/bin
- install -m 755 ${S}/bin/* ${D}${libdir}/piglit/bin
-
- cp -Pr lib/ ${D}${libdir}/piglit/
- cp -Pr framework/ ${D}${libdir}/piglit/
- cp -Pr generated_tests/ ${D}${libdir}/piglit/
- cp -Pr tests/ ${D}${libdir}/piglit/
- cp -Pr templates/ ${D}${libdir}/piglit/
-
- sed -i -e 's|sys.path.append(.*)|sys.path.append("${libdir}/piglit")|' ${D}${bindir}/piglit-*.py
- sed -i -e 's|^templatedir = .*$|templatedir = "${libdir}/piglit/templates"|' ${D}${bindir}/piglit-summary-html.py
-}
-
FILES_${PN}-dbg += "${libdir}/piglit/*/.debug/"
-RDEPENDS_${PN} = "python waffle python-json python-subprocess \
+RDEPENDS_${PN} = "waffle python python-mako python-json python-subprocess \
+ python-argparse python-importlib python-unixadmin \
python-multiprocessing python-textutils python-netserver python-shell \
mesa-demos bash \
"
+
+INSANE_SKIP_${PN} += "dev-so" \ No newline at end of file