summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-12-29 10:44:13 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-12-30 23:38:12 +0000
commit312e9fe3f047547df4c21c8e666cc9aa70e15347 (patch)
treede6fdd6e8bd855ba97bc8b0266985ee9778da3b4 /meta/recipes-graphics
parent8413dede13efa8950b0135e09ae104a38c36649c (diff)
downloadopenembedded-core-contrib-312e9fe3f047547df4c21c8e666cc9aa70e15347.tar.gz
recipes: Use -fcommon explicitly
This is needed with gcc 10 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.2.bb2
-rw-r--r--meta/recipes-graphics/menu-cache/menu-cache_1.1.0.bb2
-rw-r--r--meta/recipes-graphics/mesa/mesa_19.2.4.bb2
-rw-r--r--meta/recipes-graphics/xorg-xserver/xserver-xorg_1.20.6.bb2
4 files changed, 8 insertions, 0 deletions
diff --git a/meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.2.bb b/meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.2.bb
index b9961c398c..675ee40fa4 100644
--- a/meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.2.bb
+++ b/meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.2.bb
@@ -21,6 +21,8 @@ inherit autotools pkgconfig features_check
# depends on virtual/libx11
REQUIRED_DISTRO_FEATURES = "x11"
+CFLAGS += "-fcommon"
+
FILES_${PN} = "${bindir}/* \
${datadir}/matchbox \
${sysconfdir}/matchbox \
diff --git a/meta/recipes-graphics/menu-cache/menu-cache_1.1.0.bb b/meta/recipes-graphics/menu-cache/menu-cache_1.1.0.bb
index ddbbd94066..7a11228ef0 100644
--- a/meta/recipes-graphics/menu-cache/menu-cache_1.1.0.bb
+++ b/meta/recipes-graphics/menu-cache/menu-cache_1.1.0.bb
@@ -16,3 +16,5 @@ SRC_URI[sha256sum] = "ed02eb459dcb398f69b9fa5bf4dd813020405afc84331115469cdf7be9
UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/lxde/files/menu-cache/1.1/"
inherit autotools gettext pkgconfig gtk-doc
+
+CFLAGS += "-fcommon"
diff --git a/meta/recipes-graphics/mesa/mesa_19.2.4.bb b/meta/recipes-graphics/mesa/mesa_19.2.4.bb
index 46ecee3a73..115663b066 100644
--- a/meta/recipes-graphics/mesa/mesa_19.2.4.bb
+++ b/meta/recipes-graphics/mesa/mesa_19.2.4.bb
@@ -13,6 +13,8 @@ SRC_URI[sha256sum] = "09000a0f7dbbd82e193b81a8f1bf0c118eab7ca975c0329181968596e5
UPSTREAM_CHECK_GITTAGREGEX = "mesa-(?P<pver>\d+(\.\d+)+)"
+CFLAGS += "-fcommon"
+
#because we cannot rely on the fact that all apps will use pkgconfig,
#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER
do_install_append() {
diff --git a/meta/recipes-graphics/xorg-xserver/xserver-xorg_1.20.6.bb b/meta/recipes-graphics/xorg-xserver/xserver-xorg_1.20.6.bb
index 9218b4f69d..a1cd490394 100644
--- a/meta/recipes-graphics/xorg-xserver/xserver-xorg_1.20.6.bb
+++ b/meta/recipes-graphics/xorg-xserver/xserver-xorg_1.20.6.bb
@@ -8,6 +8,8 @@ SRC_URI += "file://0001-xf86pciBus.c-use-Intel-ddx-only-for-pre-gen4-hardwar.pat
SRC_URI[md5sum] = "a98170084f2c8fed480d2ff601f8a14b"
SRC_URI[sha256sum] = "6316146304e6e8a36d5904987ae2917b5d5b195dc9fc63d67f7aca137e5a51d1"
+CFLAGS += "-fcommon"
+
# These extensions are now integrated into the server, so declare the migration
# path for in-place upgrades.