aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2015-11-16 18:05:13 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-08 10:20:09 +0000
commit73e2555cc7d529a93362b3fcfea3fbc7a4c60ca1 (patch)
tree2ab0583f3527a67d96ba0be8838d19b56ce44e68 /meta/recipes-graphics
parent1eb9e190ef3bb1170b3eaabd9f7900e7ce176624 (diff)
downloadopenembedded-core-contrib-73e2555cc7d529a93362b3fcfea3fbc7a4c60ca1.tar.gz
package_regex.inc: split the rest of the entries to their recipes
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/cairo/cairo_1.14.4.bb2
-rw-r--r--meta/recipes-graphics/libsdl/libsdl_1.2.15.bb2
-rw-r--r--meta/recipes-graphics/tslib/tslib_1.1.bb1
-rw-r--r--meta/recipes-graphics/waffle/waffle_1.5.1.bb2
-rw-r--r--meta/recipes-graphics/xorg-lib/libxkbcommon_0.5.0.bb2
5 files changed, 9 insertions, 0 deletions
diff --git a/meta/recipes-graphics/cairo/cairo_1.14.4.bb b/meta/recipes-graphics/cairo/cairo_1.14.4.bb
index 17ea851c9f..a47bfa5454 100644
--- a/meta/recipes-graphics/cairo/cairo_1.14.4.bb
+++ b/meta/recipes-graphics/cairo/cairo_1.14.4.bb
@@ -7,6 +7,8 @@ SRC_URI = "http://cairographics.org/releases/cairo-${PV}.tar.xz"
SRC_URI[md5sum] = "90a929e8fe66fb5d19b5adaaea1e9a12"
SRC_URI[sha256sum] = "f6ec9c7c844db9ec011f0d66b57ef590c45adf55393d1fc249003512522ee716"
+UPSTREAM_CHECK_REGEX = "cairo-(?P<pver>\d+(\.\d+)+)\.tar"
+
PACKAGES =+ "cairo-gobject cairo-script-interpreter cairo-perf-utils"
SUMMARY_${PN} = "The Cairo 2D vector graphics library"
diff --git a/meta/recipes-graphics/libsdl/libsdl_1.2.15.bb b/meta/recipes-graphics/libsdl/libsdl_1.2.15.bb
index b50859ae18..8b9e050f9e 100644
--- a/meta/recipes-graphics/libsdl/libsdl_1.2.15.bb
+++ b/meta/recipes-graphics/libsdl/libsdl_1.2.15.bb
@@ -26,6 +26,8 @@ SRC_URI = "http://www.libsdl.org/release/SDL-${PV}.tar.gz \
file://pkgconfig.patch \
"
+UPSTREAM_CHECK_REGEX = "SDL-(?P<pver>\d+(\.\d+)+)\.tar"
+
S = "${WORKDIR}/SDL-${PV}"
SRC_URI[md5sum] = "9d96df8417572a2afb781a7c4c811a85"
diff --git a/meta/recipes-graphics/tslib/tslib_1.1.bb b/meta/recipes-graphics/tslib/tslib_1.1.bb
index 6d8c7dd7eb..8e304a6efd 100644
--- a/meta/recipes-graphics/tslib/tslib_1.1.bb
+++ b/meta/recipes-graphics/tslib/tslib_1.1.bb
@@ -18,6 +18,7 @@ SRC_URI = "https://github.com/kergoth/tslib/releases/download/${PV}/tslib-${PV}.
SRC_URI[md5sum] = "14771f8607b341bb4b297819d37e837d"
SRC_URI[sha256sum] = "fe35e5f710ea933b118f710e2ce4403ac076fe69926b570333867d4de082a51c"
+UPSTREAM_CHECK_URI = "https://github.com/kergoth/tslib/releases"
inherit autotools pkgconfig
diff --git a/meta/recipes-graphics/waffle/waffle_1.5.1.bb b/meta/recipes-graphics/waffle/waffle_1.5.1.bb
index af84020532..6e779485b7 100644
--- a/meta/recipes-graphics/waffle/waffle_1.5.1.bb
+++ b/meta/recipes-graphics/waffle/waffle_1.5.1.bb
@@ -9,6 +9,8 @@ SRC_URI = "http://waffle-gl.org/files/release/${BPN}-${PV}/${BPN}-${PV}.tar.xz \
SRC_URI[md5sum] = "c0d802bc3d0aba87c51e423a3a8bdd69"
SRC_URI[sha256sum] = "cbab0e926515064e818bf089a5af04be33307e5f40d07659fb40d59b2bfe20aa"
+UPSTREAM_CHECK_URI = "http://www.waffle-gl.org/releases.html"
+
inherit cmake distro_features_check lib_package
# This should be overridden per-machine to reflect the capabilities of the GL
diff --git a/meta/recipes-graphics/xorg-lib/libxkbcommon_0.5.0.bb b/meta/recipes-graphics/xorg-lib/libxkbcommon_0.5.0.bb
index a166b57603..de22a81972 100644
--- a/meta/recipes-graphics/xorg-lib/libxkbcommon_0.5.0.bb
+++ b/meta/recipes-graphics/xorg-lib/libxkbcommon_0.5.0.bb
@@ -12,6 +12,8 @@ SRC_URI = "http://xkbcommon.org/download/${BPN}-${PV}.tar.xz"
SRC_URI[md5sum] = "2e1faeafcc609c30af3a561a91e84158"
SRC_URI[sha256sum] = "90bd7824742b9a6f52a6cf80e2cadd6f5349cf600a358d08260772615b89d19c"
+UPSTREAM_CHECK_URI = "http://xkbcommon.org/"
+
inherit autotools pkgconfig
EXTRA_OECONF = "--disable-docs"